I can achieve that by rendering the image 2 times, but only using denoise on the first image. But that would double my render time, so i can't do that.

I want to use denoise, but on some places of the image i don't want denoise so i want to erase the denoised image and reveal the underlying non denoised image in photoshop. Maybe there is a way to use "denoise" on compositing stage.?

Is this possible?

  • $\begingroup$ In 2.8 there's a "Noisy Image" output along side the "Image" output in the compositor. $\endgroup$ – gandalf3 Mar 24 '19 at 20:25
  • $\begingroup$ You don't need to go to photoshop at all. Use two layers, as indicated by @FFeller, use the compositor to mix them together using a mask. $\endgroup$ – user1853 Mar 24 '19 at 20:41
  • $\begingroup$ I have version 2.79, this might solve my problem with that noisy image output in 2.8. The solution with the two render layers doesn't solve the problem because it renders the images one after the other. $\endgroup$ – Pusyicecream Mar 24 '19 at 22:08
  • $\begingroup$ It works the same for 2.79. $\endgroup$ – user1853 Mar 25 '19 at 1:05

Just create two render layers and turn on denoising only one of them. You will get both image the same time. enter image description here

  • $\begingroup$ If i do that it renders one image after the other and just adds the denoise on the second one, so i get twice the render time. $\endgroup$ – Pusyicecream Mar 24 '19 at 22:05
  • $\begingroup$ That is normal. If you render more than one layers it will render as many times as they are layers to be rendered. Denoise is applied as the layers are rendering, it can't be applied on already rendered images. If you need one without denoise and one with denoise you will need to render twice no matter what. This solution will allow you to do what you want: so that you can have two separate layers that be composited together $\endgroup$ – user1853 Mar 25 '19 at 1:03

As of Blender 2.81, both noisy and denoised images can be rendered in a single pass using node based compositing.

Warning, the Denoise Node is using Intel OpenImageDenoise library which is different than the original Cycles one that you get with the Denoising Check box in your View Layer setting.

  1. In the View Layer, turn on denoising data in your render pass denoising data turned on
  2. Create a compositing node with the new Denoise node and a File Output for your denoised render denoised compositing nodes

Notes: I have found that using HDR check box in the denoise node gives more detailed results in highlights with default rendering settings. This may vary depending on your scene or compositing filters. Also, all the Denoise Data outputs like Depth, Shadowing, Variance etc.. are computed internally but not used by the current Denoising node. See https://developer.blender.org/D4304 for more info.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.