4
$\begingroup$

In previous versions of blender you could have the background image be always lined up with the camera, so it was possible to align the 3D view to match with the perspective of a reference image. Example from this link

enter image description here

in 2.8

enter image description here

Is there a setting I don't know to do this? I really would love to avoid using constraints on the empty.

$\endgroup$
  • $\begingroup$ See point 2 in my answer $\endgroup$ – Duarte Farrajota Ramos Mar 24 '19 at 2:42
  • $\begingroup$ So, @DuarteFarrajotaRamos I'm sorry I just don't get it. How do I do what is shown on the first gif? where the camera moves, but the background image stays put? $\endgroup$ – user1853 Mar 24 '19 at 2:48
  • $\begingroup$ You have to use the new Camera background image feature in 2.8. The image is added directly on a camera object instead of an empty. Select a camera object and choose it from the object data tab $\endgroup$ – Duarte Farrajota Ramos Mar 24 '19 at 2:53
  • $\begingroup$ Let us continue this discussion in chat. $\endgroup$ – user1853 Mar 24 '19 at 2:58
3
$\begingroup$

With the camera selected, find the camera settings in the Properties window.

Enable Camera background.

Select the image.

enter image description here

The image will now show when using camera view.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ You sir, made my day! Thank you :) $\endgroup$ – Boris Rusev Nov 16 '19 at 17:13
  • $\begingroup$ Also ensure "Show Overlay" is turned on for this Camera BG to show up on 3D View. It does not seem to render however... $\endgroup$ – Blender Sushi Guy Apr 19 at 6:28
  • $\begingroup$ This so does not work for me in 2.82. I set up everything like you said but I see no image anywhere :( $\endgroup$ – yarun can May 14 at 19:12