2
$\begingroup$

Say I want to make a 100 fps video, can I not preview it at 100 fps over the timeline? Playback over 60 fps always displays "60 fps" on the playback screen.

Meaning I can create 1000 fps videos but I can only preview it in 60 fps in blender? Any work arounds or addons to fix this? I'd want up to 100 fps playback.

$\endgroup$
  • $\begingroup$ Interesting Question, since we can see frame rates beyond 60fps in future (current) standards. E.g. ITU-R BT.2020 or 2100, which support up to 120fps. However, there might be two limiting factors: 1, your monitor refresh rate, or 2, the Blender UI is drawn at 60fps. (I believe - please correct if mistaken). Maybe even the whole desktop environment runs at 60fps. - Would be interesting to know where the limit comes from; i.e. the technical background. $\endgroup$ – michaelh Mar 23 '19 at 23:15
  • $\begingroup$ @michaelh I don't know about Blender's UI, but the OS definitely allows apps to refresh more often than 60 times per second, and many gamers swear they can see the difference. As for me though, I'm perfectly fine with capping YouTube at 30 FPS. $\endgroup$ – John Dvorak Mar 24 '19 at 5:46
  • $\begingroup$ @JohnDvorak Yeah! But I believe one has to distinguish between OpenGL drawing for games and UI drawing. But then, the Blender viewport should be OpenGL. $\endgroup$ – michaelh Mar 24 '19 at 12:46
1
$\begingroup$

The maximum fps that can be played back will depend on your computer and the complexity of the scene in blender.

The syncronze playback option tells blender to play every frame or drop frames to keep playback in sync with time. You set the fps at the 100 you want in the final output video, then if the scene can be played at 100 fps it will be, otherwise frames will be dropped so that playback will be in sync timewise.

The interface preferences can be set to display the fps that are being played, when frames are being dropped the fps will be drawn in red.

$\endgroup$
  • 1
    $\begingroup$ I'm aware of all this. Test for yourself in a blank .blend file. Set fps to 200, set the timeline across 200 frames. Play it back with av sync, it will play the section in 1 second. The vse preview window and 3d viewport will display the display rate as hitting a max of 60fps. If you change to no sync it will take about 1.5-2x longer to play but will play every frame. Thus the question as posed on how to fix or what can be done. $\endgroup$ – kite Mar 25 '19 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.