10
$\begingroup$

I've bought Cup models from Internet.

When opening .blend file I get Blender's Interface changed. To avoid this I've unchecked "Load UI" on opening the file.

But now I cannot see the objects of the project (I can see and render them when opening the file and leaving "Load UI" checked).

"Collection 1" on the "Objects Panel" (Don't know if it is it's name). is grayed out.

cup-models.blend with LOAD UI:

enter image description here

cup-models.blend without LOAD UI:

enter image description here

Blender 2.8:

enter image description here

$\endgroup$
6
  • $\begingroup$ Can you enable the "eye" icon in the outliner? i.sstatic.net/2MTtT.gif $\endgroup$
    – user1853
    Commented Mar 23, 2019 at 19:30
  • $\begingroup$ Nope. I can't do that $\endgroup$
    – ogondiaz
    Commented Mar 23, 2019 at 19:33
  • $\begingroup$ Are you using the latest version of 2.8? $\endgroup$
    – user1853
    Commented Mar 23, 2019 at 19:34
  • $\begingroup$ Yes. The one relased on the 21st. I'll put an image of the version on my question. $\endgroup$
    – ogondiaz
    Commented Mar 23, 2019 at 19:40
  • 3
    $\begingroup$ And there is YET another (apart from "Exclude from View Layer" and the simple "Hide") hiding option which is... hiding... under Right Click - Visibility - Disable in Viewports. That greys the thing out, too. It also seems to default to this when an older .blend was opened in 2.8 that contained multiple things in not-visible (at the time of saving) layers. $\endgroup$
    – BuzzKirill
    Commented Jul 4, 2019 at 9:03

5 Answers 5

15
$\begingroup$

tl;dr: Your collections are set to be excluded from the scene.

This is the Blender 2.80 replacement for enabling/disabling layers. Instead of selecting or deselecting a couple of layers in your viewport, you set your collection to be excluded from the viewport.

Go to the Outliner, left-click on one or Shift + left-click on multiple collections, right-click to open the Menu and go to "View Layer" and click "Clear Exclude" - alternatively hit the Shortcut Alt+E while your mouse pointer is within the Outliner.

clear exclude

$\endgroup$
5
  • 6
    $\begingroup$ For some reason this feature was removed in one of the release candidates, and then added again (but renamed) in the final 2.8 release. The latest version has it, but it's called Enable in Viewports/Disable in Viewports in the same sub-menu. However, the ALT+E shortcut doesn't work anymore. EDIT: it's not in the View Layer sub-menu anymore, it's in the Visibility sub-menu. $\endgroup$ Commented Jul 30, 2019 at 21:37
  • $\begingroup$ The answer should be updated with your comment. $\endgroup$ Commented Feb 3, 2020 at 8:34
  • $\begingroup$ It's still the same in Blender 2.81a and 2.82. If everything is greyed out, move your mouse pointer within the outliner, hit Alt+E and your objects should reappear. If one or more collections are visible in the outliner, right-click on one collection and you'll find the "View Layer" submenu. $\endgroup$ Commented Feb 15, 2020 at 16:37
  • 1
    $\begingroup$ The fix mentioned above didn't work for me, but led me in the right direction: My whole collection was enabled, but some objects were still invisible. I fixed this by selecting those objects and navigating to Properties => Object Properties => Visibility => "Show in Viewport". $\endgroup$
    – 2v0mjdrl
    Commented May 7, 2020 at 12:56
  • $\begingroup$ Unfortunately, none of the suggestions in comments work for me. These objects remain grayed out after updating my blend file to 2.82.7 $\endgroup$ Commented Nov 2, 2020 at 13:22
1
$\begingroup$

For anyone using version 2.93.5 .. this is where I made the grey game object visible enter image description here

$\endgroup$
0
$\begingroup$

For anyone using Blender 3.2.1:

  1. Find the grayed-out "Collection" in the Outliner.
  2. Right-click.
  3. Visibility.
  4. Enable in Viewports.
$\endgroup$
0
$\begingroup$

If it's useful for anyone: I was really puzzled why a mesh was greyed out in the outliner, turned out it was in a collection which was set not to render in the viewport, so all its children were greyed out - but collections were not shown in the outliner. Solution was to enable collections on the outliner filter, then i could re-enable them.

$\endgroup$
-1
$\begingroup$

Anyone looking for this answere, none of the upper solutions worked for me, what I did was moving all meshes that where greyed out to the default activated Collection, there is one that show everything inside normally. Just move all your mesh to that one and then separate everything in new Collections.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .