1
$\begingroup$

I'm new to Blender and I was painting the texture of my model but I accidentally clicked on F mask brush and now I can't paint anymore. I do not know how to remove this I tried to restart Blender but it doesn't work.

K

Also when I start a new file it said that "Missing Data" something about texture slots.

enter image description here

edit: I have this brush selected.

enter image description here

edit2: the first three are of the brush I want to paint, the other three are of the F Mask brush enter image description here

$\endgroup$

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • $\begingroup$ Your blend file might be helpful to make sure, but my theory is, that by removing the fake user (when you clicked the F-Button) the texture file got flushed. Try clicking on the dropdown that says "Add new Paint Slot". That should give you a fresh one with which you can continue to work. $\endgroup$ – Ben Mar 22 at 7:14
  • $\begingroup$ When I tried this on my end just now, after unchecking the F-Button, the Stencil for the brush had been removed. So I simply re-assigned it from the Slots Tab in the Tool Palette (Press T to toggle it on/off) $\endgroup$ – Ben Mar 22 at 7:40
  • $\begingroup$ yes doesn’t look easy to come back to the basic texture brush once you’ve selected the mask brush, but in the Tools tab, if you select a Stencil Image under the Missing Data message, then choose back the F TexDraw, then in the Slots tab, in the dropdwon menu, switch from Painting Mode > Image to Painting, choose a Canvas Image, and uncheck the Mask option, it works back. Don’t ask me what I’ve done though, if someone could explain all this it would be great :)) Also, when you create an image in the UV/Image Editor, don't forget to save it (Pack as PNG if you want to save it within the file) $\endgroup$ – moonboots Mar 22 at 9:28
0
$\begingroup$

In that first image, you do not show what tool you are using - cannot see the error here, other than you need to be sure you are using the correct paint tool.

Second image, you have to assign a new image texture to get a slot before you can paint - simply add one and you can begin painting so long as your canvas object has UVs.

$\endgroup$
  • $\begingroup$ I add a photo of the brush i have selected, but it dosen't work $\endgroup$ – Karen R Mar 22 at 16:23
  • $\begingroup$ Get me a closer look at the whole tab with the brush texture and brush mask settings as well $\endgroup$ – Craig D Jones Mar 22 at 17:08
  • $\begingroup$ yes, took the picture. Just in any case, I leave the link of the file [link] (drive.google.com/file/d/1_rgF4xvkoh-wq5X0N926i1fwQBj6HMuO/…) $\endgroup$ – Karen R Mar 22 at 19:06
  • $\begingroup$ Turn off the Mask in the Slots tab - with the texture used there, it is negating any use of the brush. $\endgroup$ – Craig D Jones Mar 22 at 20:51
  • 1
    $\begingroup$ thank you! it works!! $\endgroup$ – Karen R Mar 23 at 4:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.