0
$\begingroup$

I often model separate pieces and modify them with boolean operations to get to a final result. I'm stuck with a quarter of a cone intersecting with a hollowed cube (think of an inverted tray). My goal is the union of the cone and the smaller portion of the cube/tray. In other words the cone is larger than the diagonal of the tray. I'm not getting desired result in Blender 2.77, but I really think I'm missing a step somewhere. If you don't have and answer for that, how about a link to steps to manually do it? It really is simple, but I'm afraid I've been away too long. Thanks for your thoughts. Looks like it worked - Nope

$\endgroup$
2
$\begingroup$

The problem is that your mesh is non-manifold, meaning you have holes on its surface, it can't boolean properly. To fix that, go in Edit mode, select the whole mesh, go in the Mesh menu > Clean Up > Fill Holes. Also you should recalculate the normals with a ctrlN even if it seems to work with bad normals. Then boolean with the Union mode and it works.

enter image description here

$\endgroup$
  • $\begingroup$ I used the "clean up" options in several different passes during the path to this point. Your observation is that one should use those tools just before doing a boolean modification. Is there a required order? Did "fill holes" take care of the problem or did you have to apply patches individually? $\endgroup$ – Hertfordkc Mar 22 '19 at 11:04
  • $\begingroup$ Thank you for responding. I'm off to see if I can replicate. $\endgroup$ – Hertfordkc Mar 22 '19 at 11:09
  • $\begingroup$ I don't understand what you mean, what I've done is simply select your object, go in edit mode, Mesh > Clean Up > Fill Holes, then boolean, and it works, so if you tried the same thing and it didn't work I don't know the reason $\endgroup$ – moonboots Mar 22 '19 at 11:41
  • $\begingroup$ Sorry for confusion. I had earlier tried "Fill Holes" but apparently had other errors which kept the boolean from working. Following your suggestion, I went to "Clean Up" and then every option on its menu and it worked. I'm not suggesting it is a bug; I'm confessing that I'm not methodical in my work flow. Thanks again. $\endgroup$ – Hertfordkc Mar 22 '19 at 14:52
  • $\begingroup$ I'm not sure but sometimes it looks like there are some bugs with booleans, but in your case it looks like when you fill the holes it works perfectly... your mesh is a bit messy though, but it's another problem ;) $\endgroup$ – moonboots Mar 22 '19 at 15:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.