0
$\begingroup$

Any ideas on how to fix this bug/feature of Blender? How can something so simple like selecting another action mess with my work?!

Here is the video: https://youtu.be/YE8sNfaVu6o And the .blend file: http://www.filedropper.com/mccree28

$\endgroup$
0
$\begingroup$

It's not a bug, for the action called TestAction.001 you can see that a LocRotScale track has been created, it means that, additionally to the keyframes you've created for the bones, you've created some keyframes for the whole armature in Object mode. And if you unfold this track you'll see that you have Scale keyframes as well as Location and Rotation keyframes. So delete the whole track, then, as it has changed the size of your armature when you've selected it in the Dopesheet, just select the armature and altS to reset the scale.

enter image description here

$\endgroup$
  • $\begingroup$ Thanks! That solved it. Still, it seams weird that scale doesn't return to normal when switching back to 'run' action, but remains small. I thought actions are completely separate. (this was behavior before deleting LocRotScale; now it all works) $\endgroup$ – Nezio Mar 21 at 15:08
  • $\begingroup$ it remains small because it keeps its last scale setup! i.e. the one determined by the LocRotScale keyframes. If the other animations had scale keyframes it would have come back to those new ones. $\endgroup$ – moonboots Mar 21 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.