0
$\begingroup$

BACKGROUND

So, I have a project that I am working on, the control panel of the Apollo 11 spacecraft. I finished modeling it and texturing and rendered an animation. It all was fine and ended up with a short video, no problem. Later I realized that in some sections the camera didn't stay long enough, so, pop back into blender, change some keyframes, voila. Render, then disaster strikes.

ISSUE

The time for a frame started at around 8 secs then ended up at about 5 mins. After watching it for a while the time steadily goes up as it gets further through the animation, there's also a lot of time going into "updating shaders".

ATTEMPTED FIXES

Tried changing tile size from 64x64 to 128x128 and 256x256 didn't fix. Prevented it from using my CPU, but didn't help. I've looked at task manager performance and only 1% of my GPU is being used, about 3% of my CPU and around 30% of my RAM. Maybe there is some sort of restriction in the settings? Any help would be much appreciated, thanks in advance for any replies.

HARDWARE

RTX 2070 - GPU

Ryzen 5 2600 - CPU

Gigabyte b450m ds3h - MOBO

Samsung 970 EVO - M.2 NVME SSD

Western Digital - HARD DRIVE

Corsair Vengeance LPX 32GB DDR4-3200 - RAM

SOFTWARE

Windows 10

Blender 2.8

$\endgroup$
8
  • $\begingroup$ As you know 2.8 is still in beta, so it can still be buggy, specially when it comes to supporting newer hardware like the RTX cards. Maybe there is information on this link: blender.stackexchange.com/questions/119837/… $\endgroup$ – user1853 Mar 20 '19 at 19:56
  • $\begingroup$ Yes, I believe I performed the fix listed on that link, and have had no problems thus far, doing other projects within 2.79, (which I mainly use), or 2.8. It may also be worth noting that this project began in 2.79, then was opened in 2.8 to put the new version to use, so that transition may have caused the issue. Do you think it's just a bug then? And if so is there any way to export it back into 2.79? $\endgroup$ – TheArrowhead 984 Mar 20 '19 at 20:15
  • $\begingroup$ I tried opening it, by the way, blank project as far as I can see, empty viewport, blank outliner and messed up U.I., presumably due to the differences between the versions design $\endgroup$ – TheArrowhead 984 Mar 20 '19 at 20:16
  • $\begingroup$ For any serious work stay in 2.79, specially for cycles. Beta is always a tossup. But if you modified the file and saved it with the same name in 2.8 you won't be able to open it in previous versions. Do you have a backup? $\endgroup$ – user1853 Mar 20 '19 at 20:21
  • $\begingroup$ Will do in future, though I stupidly thought you could open 2.8 files in 2.79 so didn't make a backup. I have now tried exporting at Collada and Alembic. Neither worked as I hoped, the Collada kept the materials, lost the textures and messed up the geometry, and the Alembic lost all materials and texture but kept the geometry, and lost animation data, I suspect the Collada lost animation data too, though did not check so cannot say for sure $\endgroup$ – TheArrowhead 984 Mar 20 '19 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.