0
$\begingroup$

i'm having a rookie issue. I'm trying to make a train station, which would include a train. Problem is that i can't render anything without blender crashing. This is: Blender 2.8 Eevee or Cycles (here is were i originally made the models). I also tried transfering the train in the picture to 2.79 (this changed nothing). Notice everything is set to render in 1280x720 px and with 150 samples. I tried rendering with the subsivision modifier "on" and "off". Blender crashes every time. On the bottom righ of the pictures below you'll see my faces count, i'm guessing its ridiculously high, but i need the detail to achieve i a photorealistic effect (hopefully). I simply mean to get still images, nothing more. Anyone knows a possible solution?

Edit 1: I neglected to provide my laptop's specs, is not tthat grate but shouldn't be a problem (read edit 2):

Operating System Windows 10 Home 64-bit CPU Intel Core i7 @ 2.70GHz 42 °C Kaby Lake-U/Y 14nm Technology RAM 8,00GB Single-Channel Unknown @ 1063MHz Graphics

Intel HD Graphics 620 (HP)
4095MB NVIDIA GeForce 940MX (HP)

Storage 931GB Western Digital WDC WD10JPVX-60JC3T0 (SATA) 30 °C 119GB SanDisk SD8SNAT-128G-1006 (SSD)

Edit 2: I've done more before I figure i'd check an old render i did on on blender 2.79, on this very same specs. I was able to render with no issues and the faces count was of almost 12 millions. Now i tried rendering the first picture (1.5 million faces), following the instructions left by one of the guys (lower sub-divs levels and use cycles). Still crashed. Could it be a Blender 2.8 BETA thing?

Subdivision "ON" Renders at level 6

Subdivision "OFF"

The whole scene (no textures yet) in case u wanna know what i'm up against

$\endgroup$
1
$\begingroup$
  1. Lower your subdivision modifier from 6 to 3 (at most: 3).
  2. Please check double geometry on all of your models (even simpler ones) There could be intersecting double faces. Enter edit mode, press F3 (to search) or Spacebar (user preferences to set spacebar to search) and while in edit mode, type "remove doubles". You´ll get notification on how many edges were cleaned.
  3. Also check your materials don't contain special characters, this is another reason why in the process of "pre-processing" before rendering the render crashes. Make sure spaces are appropiate (use a "." or "_" to separate numbered versions of the materials or the meshes)
  4. 6 millions of polygons shouldn´t be a big deal if you have 12GB+ of Ram. Also switch to CPU rendering only. Do not process with EEVEE. Use Cycles. /// I´ve render 15 million polys on Cycles on CPU due to the lack of processing on 12GB VRam for GPU on my Titan X card. So you may as well play safe on the Cycles CPU render part thus answering this question.

Thank you for your consideration to vote me as the answer by clicking to the left :the icon with a check mark and upvote this answer.

BFCT_Schiller

$\endgroup$
  • $\begingroup$ Hey Pierre thanks for helping out, just tried what you suggested but i think something else is going on. Check the edits i left on the main question if you want to know more. $\endgroup$ – Nicolas Lovito Mar 19 at 14:46
  • $\begingroup$ Hi. Thanks for the specs. If you´re on windows, go to : c:\users\yourUserMachine\AppData\Roaming\Blender Foundation\Blender and delete blender 2.8 folder (this is preferences folder). After that download daily version and run it. A new pref folder will be created automatically. Sounds like you have a .py script bugging there somewhere. Delete. clean. Run. It will work. $\endgroup$ – Pierre Schiller Mar 19 at 20:11
  • $\begingroup$ OH! BTW: Save your file with a different (shorter name) and also APPLY the mirror modifier FIRST. Then you can leave the other two (array and sub-d). But please APPLY mirror. This is causing the issue as well. You have a collection of specific setups that disrupt system to render. $\endgroup$ – Pierre Schiller Mar 19 at 20:13
  • 1
    $\begingroup$ Hi again. I got it working, by keeping the train and the station in diferent files. The sub-div levels were the proble Just like you said. I'm going to do what you said in this lasts comments, maybe i can get everything working even smother. Thanks for everything, PS; I'm upvoting but it might not show, as i'm a rookie user my votes are not displayed publicly. $\endgroup$ – Nicolas Lovito Mar 19 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.