0
$\begingroup$

https://blenderartists.org/t/textures-dont-show-when-rendering/1151729/2

I've been having trouble getting the textures to show up while rendering a character I've been working on. It'll show up while on the texture view but when I go to render, it'll be completely black or transparent. How do I fix the textures not rendering.

$\endgroup$
  • $\begingroup$ Can you add a picture of your material nodes to the question? Do you have a light in your scene? $\endgroup$ – Sazerac Mar 18 '19 at 23:42
2
$\begingroup$

Okay, so here's your problem: enter image description here

Your image node settings for your textures are set to "Clip" when they should be "Repeat". As you can see by my screenshot, it now works.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thx for help. Does that work for all the problems like that or is more complex than that? $\endgroup$ – Joey Scranton Mar 18 '19 at 22:30
  • $\begingroup$ For the most part, yes. You virtually always want that option to be set to Repeat. That's why it's the default option. ;-) $\endgroup$ – Samino Mar 18 '19 at 22:33
  • $\begingroup$ Honestly I've never noticed. I just assumed that the picture would work just throwing it in there, plus images as planes does the hard part of using a texture in cycles. $\endgroup$ – Joey Scranton Mar 18 '19 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.