3
$\begingroup$

enter image description here

I do not know why. The tutorial I followed was https://www.youtube.com/watch?v=D_ybn4tYxs4.

I am not able to get the result of a nicely shaped flame.

Below is my set up for the domain:

enter image description here enter image description here

$\endgroup$
1
$\begingroup$

You have brightness set to 1 on both of your bright contrast nodes, it should be 0 as you don't want to modify the brightness at all, increasing the brightness like this is effectively setting the background density to a value above zero, so the whole cube is being rendered.

In fact you don't even need those nodes at all

The other thing I noticed is the top attribute node should use the density attribute for the smoke, rather than the flame attribute.

In order for volumetric materials to render correctly you will also need to go to the light paths section of the render settings and set the number of volume bounces to something reasonable.

$\endgroup$
  • $\begingroup$ henlow, I have tried this again with the bright contrast nodes removed, but my flames died. imgur.com/a/RtLLA18 I am not sure what to do anymore $\endgroup$ – lala Mar 18 '19 at 7:14
  • $\begingroup$ @lala Try plugging in just the emission shader to the volume output and see what you get $\endgroup$ – Sazerac Mar 18 '19 at 7:24
  • $\begingroup$ Still dead flame. Would you like me to send my file for you to inspect? [link]i.stack.imgur.com/wx23p.png] $\endgroup$ – lala Mar 18 '19 at 7:53
  • $\begingroup$ @lala sure, that would make it easier. $\endgroup$ – Sazerac Mar 18 '19 at 7:56
  • $\begingroup$ here ya go drive.google.com/open?id=1RE7-TEOMjem_NcHoK-v1uv3GOfHXailr $\endgroup$ – lala Mar 18 '19 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.