1
$\begingroup$

Fluid simulation won't happen in my model pipe. I Got a project from my client in which fuel must pass through a pipe. so I tried to do the simulation but the simulation won't happen. I tried scaling the inflow and domain. Why is this happening?enter image description here

$\endgroup$
2
$\begingroup$

Most likely your pipe/inflow is too narrow/small for your simulation resolution - it must be at least comparable to the size of the “cells” of your simulation.

You can determine the size of the “cells” by taking the longest dimension of your fluid domain and dividing it by the fluid domain’s Resolution - your pipe should typically be at least three times the size of the cells, otherwise the flow of fluid can be blocked - especially on diagonal sections and curves; much higher resolution is preferable.

However, the overhead of the simulation will increase significantly with higher resolution, with an increase relative to the cube of the increase in resolution - so doubling the resolution will allow for pipes that are half as narrow but will take 8 times (ie, 2x2x2) the overhead (memory and CPU comutation time) to compute.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.