0
$\begingroup$

What is the proper way to import fbx from Nuke ? Does anyone has a successful experience ? I always fail to orient the scene properly. The best setup is to set FORWARD to -Z forward and set UP to Y up but the X axis is always reversed. Any trick for this ?

Thanks

$\endgroup$
  • $\begingroup$ related? blender.stackexchange.com/questions/20859/… $\endgroup$ – cegaton Mar 13 at 14:48
  • $\begingroup$ No, i'm imported to Blender, not export. There's no ascii option in blender import fbx setting. Also when i write fbx out from Nuke and set as ascii, Blender will throw error saying "ascii in not supported...." . I'm using blender 2.8. $\endgroup$ – andio Mar 13 at 15:13
0
$\begingroup$

I find a way to fix the rotation , this is my setup in fbx import parameter : turn on manual orientation and set forwar to -Z forward and up to Y up. Then DO NOT use the camera directly , but used it as reference only. Create a new camera, go to constraint property and choose 'child of' and select the original camera as parent. now clear out all translation/rot/scale of the new camera and set X and Z rotation to 180. Now i can see through the new camera.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.