3
$\begingroup$

I've been messing around with Tilt Brush recently and want to make a short revolve animation around some of my sketches.

So I've imported a sketch as a .fbx file in Blender but can't seem to get my head around getting the brush materials/textures to show in the render. I see in the cycles nodes that materials have come across but everything is white. Is it a case of manually rejigging the materials, or am I missing something?

Any help appreciated, thank you!

$\endgroup$
2
$\begingroup$

I have been facing the same issues and so far I have figured out the following.

  1. Change the default vertex color name from 'color' to something else (I used 'col1'). “color” named vertex color layers are not working for some reason.
  2. Create an Attribute node in the node graph
  3. Use the vertex color name that you used in step 1
  4. Connect the Attribute.color to BSDF.Base Color

enter image description here

For the textures, the following setup seems to be working

  1. Select the tilt brush stroke mesh
  2. Set the material blend mode to Alpha Clip
  3. Add an Attribute node and choose the vertex color channel
  4. We will use the Texture node's alpha
  5. Use the alpha as a multiplier with a custom value
  6. Create an emission node

I am still working on making the texture workflow better, hope this helps.

enter image description here

UPDATE

Using a Transparent BSDF and a mix shader better results can be obtained. Following is an example using Cycles. With Cycles there are no Blend mode options (as specified in the original answer. Blend modes are EEVEE specific)

enter image description here

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.