4
$\begingroup$

New to Blender 2.8. Working on a Blender Guru Anvil tutorial. How do I hide multiple vertices, but keep the object mesh visible? Andrew seems to get this to work in 2.7, but it's not working for me in 2.8. See 3rd image attached.

In Edit mode, I'm selecting the top vertices (orange), and I click "H"...the vertices and mesh both get hidden...not the vertices alone.

Thx!

M

enter image description here

enter image description here

enter image description here

$\endgroup$
4
  • $\begingroup$ I think you need to clarify what you need to see, exactly. The mesh is made up of vertices. Hiding them will remove the mesh. do you want to hide your mesh cage and only have the Subdivision Surface visible? Cause, that you could do with the Edit Mode Toggle on your Subdivision Surface Modifier. $\endgroup$
    – Ben
    Mar 10, 2019 at 22:13
  • $\begingroup$ This is expected behaviour ..It's a shame, IMO, that Blender works with proportional editing, not proportional (soft) selection, which would be more flexible and more powerful. The only way to prevent proportional editing from affecting a region is to hide it. As I recall, this is what happens in the anvil tutorial? You could retain a separate copy of the whole mesh , for visual comparison.. $\endgroup$
    – Robin Betts
    Mar 10, 2019 at 23:14
  • 1
    $\begingroup$ Thanks for the responses guys. I've attached a 3rd image of the result that Andrew gets from B 2.7. He's able to hide the top vertices for Proportional Editing...but the mesh object remains visible for eyeballing the proportional editing result. Andrew doesn't make a second copy of the object. $\endgroup$
    – mat10x
    Mar 11, 2019 at 1:51
  • $\begingroup$ Alternatively if there's a way to "lock" some vertices (prevent them from moving) in proportional mode without hiding them that would answer the real question (see also the answer below by @RobinBetts) being asked (this could be an XY Problem) $\endgroup$
    – Julian
    Sep 1, 2019 at 7:09

3 Answers 3

3
$\begingroup$

Quite right .. it works the way shown in the tutorial in 2.7 with these settings in the modifier:

enter image description here

..but it doesn't in 2.8:

enter image description here

.. which I would classify as an annoyance... there's always a chance there's a setting someone knows which makes this work?

$\endgroup$
1
  • 1
    $\begingroup$ I'm still at the stage where I'm finding modeling much slower and more awkward in 2.8.. I'm giving it a few months, and a release, before I come to any conclusions about whether that's the interface, or my inexperience in it. $\endgroup$
    – Robin Betts
    Mar 11, 2019 at 8:07
2
$\begingroup$

You can un-toggle "Optimal Display" in the Subdivision-Modifier and use the wireframe mode ("Z" + "4"). This shows the wireframe even for the hidden vertices. (Using Blender 2.91).

Modifier Properties

This gives a similar visualization as in the tutorial. enter image description here

$\endgroup$
0
$\begingroup$

I ran into the same problem, and Chris's answer doesn't work in Blender 3.2 (sorry, I can't comment on his answer)

I think it's because GPU subdivision has to be disabled first, and a simple workaround to do so is to enable Auto Smooth on the mesh (in the Object Data Properties tab):

Auto smooth

Then a message about GPU subdivision appears in the modifier: Subdivision modifier message

And then unchecking Optimal Display does the trick.

Maybe there is another simpler workaround but I don't know about it. Anyway it would still be useful to have a proper way to proportionaly edit such a mesh without hiding any part of it.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .