0
$\begingroup$

can anyone help me in figuring out a problem that I've been having regarding applying transparency for the image textures that comprise of my model's eye(s)?

You see, the eye(s) of my character is made up of three separate layers: the pupils, the eyelid(s) & the sclera, overlaid over one another to create the eye(s) in their entirety. In order for this to work properly, it would require the pupil & eyelid(s) textures to have transparency (the sclera is painted onto the main body) applied, but unfortunately I had trouble trying to find tutorials online on how to create a original texture image with transparency. Pretty much all the tutorials I found were for how to get transparency from a preexisting asset, rather than how to make one from scratch.

Eventually, I was able get transparency on the image textures I created by using Erase Alpha from Brush Blending Model options in Texture Paint mode. However, the transparency isn't quite working as I intended, as pupils appear to faded rather than pitch black like their suppose to.

enter image description here

There's also other visible issues as well, as highlighted in the screenshot below, such as how the pink area covered by the pupil & eyelid(s) layers appears darker than the areas not covered:

enter image description here

If no one can directly identify what is wrong with the way that the transparency is applied on my model, I was then hoping that someone could instead tell me what the proper way is of applying transparency to a self-made image texture in Blender Render. If I have to redo the textures again from the beginning, that's fine since the textures I've made were hastily made with the intent of cleaning them up later.

There's also another issue that I believe is connected, although I can't say for certain that it is, but that I would, nevertheless, like answered anyhow. This other issue, came about when I decided to try and test rendering an image and I ended up with this result:

enter image description here

The strange thing is that this result only happens when I choose to render an image, it doesn't occur in Rendered mode or any other Viewport Shading setting. Even weirder is that the visible geometry conforms exclusively to the shape of the eye(s) despite the fact that the mesh for both the pupil & eyelid(s) textures consists of a rectangular-shaped "mask". At one point I was going to make the various parts of the eye(s) into overlaid polygonal meshes, but I changed my mind and decided to deleted them. Just to be on the safe side, I looked through every component making up my model to see if I perhaps had forgotten to delete the old mesh, but I couldn't find anything like that, so there should be no reason for this to be happening. And even weirder still, the visible Quads making up the eye mesh appear to have been cut in half into Tris, which was not something I did myself.

Any help with either of these matters would be greatly appreciated!

$\endgroup$
1
$\begingroup$

Okay, it would appear I've managed fix the transparency issue on my own with the aid of this video tutorial enter link description here that was included on my YouTube Recommendations this morning. While following along with the video, I discovered that the reason for the faded look of the pupil texture was that the Diffuse Influence of the Alpha wasn't enabled in the Texture tab. Once the Alpha was enabled, the pupil looked the way that it was supposed to.

As for the eyelid(s) texture, I didn't actually find out what was wrong with it. Instead, I created a completely blank image texture in Gimp and imported onto my model. I then repainted the eyelid(s) onto the new blank image texture, and as a result, the new eyelid texture now has looks the way that is was intended without any apparent issues that were found in the old version.

However, rendering an image still results in the same problem as before, with a weird visible mesh around the eyes that only appears when a image is rendered and not in any other mode in Blender. I have no idea if this a serious issue or not, I guess I would have to import the model & its textures into Unreal Engine 4 to see if there is any visible problems whatsoever.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.