0
$\begingroup$

Ok so there's a website I have to use for school to view 3D models that I have made. When I put my model in without the textures it says that it isn't missing any files, but when I use a model I downloaded without the textures, it says it's missing files. How do I fix that? Also this isn't just limited to the website, my model just won't let me add textures to it in any other program.enter image description here

As you can see in the top left here, it says missing files and then the name of the texture enter image description here

And here, it doesn't say that there's any missing files.

Sorry I'm really new to blender and I would really appreciate a bit of help because I just spent 3 hours trying to figure out how to export the texture and I would literally cry myself to sleep knowing all that had gone to waste.

Also the website is 3dviewer.net

$\endgroup$
  • 1
    $\begingroup$ Can you explain a bit more what you are doing actually with blender? $\endgroup$ – Sazerac Mar 8 at 4:07
  • $\begingroup$ 3dviewer.net says it only supports 3ds, obj, stl and off. Which one/s are you using and what are the settings in the export (screenshots please)? $\endgroup$ – rob Mar 8 at 8:54
  • $\begingroup$ found a discussion here about that site and mtl files and how to view errors in the browser console forum.babylonjs.com/t/help-with-3d-viewer-babylon/1275 $\endgroup$ – rob Mar 8 at 9:11
  • $\begingroup$ I managed to upload a model with working texture by doing the following : -create a BLENDER INTERNAL material with a texture ; -export it in .obj (with default settings) ; -drag and drop these 3 files into the viewer : .obj, .mtl and texture (.png in my case). I hope it helps. $\endgroup$ – thibsert Mar 8 at 9:42
  • $\begingroup$ @rob it's an obj file, and my settings are default $\endgroup$ – Spicy Squid Mar 9 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.