1
$\begingroup$

This question already has an answer here:

enter image description here

Hey all,

CUDA error: Out of memory in mem_alloc_result, line 850

I'm unable to render a model I quickly put together (Is it considered simple?) When I attempt to render the scene, my system will completely crash/lock up or blender will force quit.

I'm using blender 2.8 with cycles as my render. I have GPU + CPU selected underneath CUDA in the user prefs and am trying to render at 1080x1920.

My hardware specs: GeForce GTX 1070 8gb, 16gb ram, Intel i7-7700 @ 3.60ghz

I'm confused because I feel like my model is basic. I have a sunlight lamp and materials using only a diffuse.

https://drive.google.com/file/d/1fRTEdryDYASwWVkwFRNJOR1_GJ7NGgyA/view?usp=sharing

Can anyone point me in the right direction on getting this solved? I've uploaded the blend file here if anyone would be kind enough to inspect what's going on. I'm new so I'm just trying to figure out if this is user error, or if I need a better computer!? Thank you so much! -K

$\endgroup$

marked as duplicate by cegaton cycles Mar 6 at 19:19

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1
$\begingroup$

Out of memory errors can always be traced to the same source:

Your scene and render settings exceed the resources available in your computer.

You've set subdivision surface settings for Render to a high number, some have it set to 6!

enter image description here

Do you need that many polygons? There is a huge penalty for using such large values:

For every subdivision level the number of polygons increases exponentially.

At level six you are generating 4225 extra quads for every quad of the original object... Enough to choke most computers.

Use proper modeling and less subsurf to describe the shape of the objects. You should rarely need more than a subsurf level of 3. Straight shapes with flat faces might not need any subsurf at all.

Read: Blender render crash when using subsurf modifiers..

Also keep in mind that denoising will use a lot of memory, as it has to keep information from all the surrounding tiles.

Read: Why does Denoising take up so much memory?

Try reducing the tile size as well.

$\endgroup$
  • $\begingroup$ Thank you, that did the trick! I reduced the number of subdivisions to 2, and it works great now. Appreciate your fast and thorough response! $\endgroup$ – Kasey Mahoney Mar 7 at 1:09
0
$\begingroup$

I might have found a solution. Take a look here:

https://github.com/pjreddie/darknet/issues/791

Might be a GPU memory thing.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.