2
$\begingroup$

I have the following mesh with no thickness or faces:

Original Mesh

I wish to be able to apply a uniform thickness along with clean geometry without creating too many vertices.

The solidify modifier isn't getting me what I desire:

Solidify -> Extrude

The skin modifier is getting me closer to what I want, but I am unable to control the thickness of the object, generating extra geometry from what I need and creating undesirable faces and edges.

The process here is after the skin modifier is applied, the geometry is flattened on the Z axis, vertices doubles removed, and then extruded.

Skin Modifier Undesirable Geometry Similar to what is desired

There has to be a simpler, less computationally expensive and more flexible solution to this that I am unaware of.

$\endgroup$
  • 1
    $\begingroup$ Possible duplicate of Using the solidify modifier with no deformed geometry $\endgroup$ – Duarte Farrajota Ramos Mar 6 '19 at 16:05
  • 1
    $\begingroup$ You could also not convert to mesh and use built curve tools to bevel geometry $\endgroup$ – Duarte Farrajota Ramos Mar 6 '19 at 16:05
  • $\begingroup$ In my opinion this can be avoided if you create the path objects in a vector drawing program, That way you can create curves that have width you want instead of being a single line. Export as SVGs, import in blender and give the curve some extrusion. $\endgroup$ – user1853 Mar 7 '19 at 18:24
2
$\begingroup$

Maybe there's a simpler way but you could try with the Wireframe modifier:

  • Select your mesh, fill with F.
  • Give your object a Wireframe modifier. Enable Boundary, choose the Thickness you want.
  • Apply the modifier.
  • In Edit mode, select all and flatten with a SZ0.
  • Remove doubles with a W.
  • Delete the unwanted faces.
  • Work the angles.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks! That's great, I'll book mark this and use this method from now on. $\endgroup$ – Yoshihara Mar 6 '19 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.