0
$\begingroup$

I tried to solidify a poligon extrusion, but it seems to be more complex than expected. After solidification some edges seems to cross each others, but I believe this should be a real common result because my geometry is not particulary complicated.

What can I do to correct this issue? tank you.

solidify non manifold (not continuos)

  1. extruded angle
  2. solidified angle (wireframe view)
  3. solidified angle (solid view), with crossed faces. I would like to delete only crossed faces and plug the external perimeter with a single face.

EDIT

I did a mistake during the post: the original geometry was an agle, but trying to surround the problem I added an edge (instead the angle). the @rob solution was correct for the angle! tank you @rob (very gratefull)

this part of the problem is another one: how to solidify an edge (not an angle)

solidify error after even thikness option applied

EDIT2: for completeness i post the entire geometry (cursor on problem): full geometry

the file: blender file

$\endgroup$
  • $\begingroup$ I just tried this with a single plane with and extruded edge. After setting the Soildify modifier to Even Thickness I got the result I expected. What else is in your Mesh that is affecting the Modifier? $\endgroup$ – rob Mar 6 at 15:40
  • $\begingroup$ tank you for suggestion, I tried some option of modifier, but I didn't see the difference. Now I solved partially the problem, because some solidication of the ancgle appear. tank you! but.. as you see in my EDIT, i have a new (same) problem. $\endgroup$ – Marco Mar 6 at 18:38
  • 1
    $\begingroup$ I don't get any problems with that kind of geometry. With or without Even Thickness. Probably corner vertices in your mesh are not connected to neighbour vertices so you have non-manifold / open geometry. Easiest way to fix is to select all and remove doubles. Though it's not necessary it will work if there aren't technically doubles, then some manual cleanup can be required. Hard to tell more without the file $\endgroup$ – Mr Zak Mar 6 at 19:45
  • 1
    $\begingroup$ Now I'm confused. I discovered my draw is "invisible".. I post the file to you, I can't understand why I can't see lines exept in edit mode. Note that, if you try solidify on polygone, in the famous edge the solidification is inverted. $\endgroup$ – Marco Mar 7 at 9:59
  • 1
    $\begingroup$ file added on bottom of the post $\endgroup$ – Marco Mar 7 at 10:01
2
$\begingroup$

The mesh object has quite a bit of double vertices shown in the example below. They will prevent modifier from working properly as if extruded they will create even more intersections leading to z-fighting even without solidifying.

enter image description here

Selecting all and removing doubles in Edit mode solves that as they are intersecting with each other. Then extrusion should be done to have faces Solidify to work with. After extruding by default Blender orients half of normals to one side and half - to another.

enter image description here

Blue lines show normals orientation. According to that modifier will orient half of faces to one side and half to another one leading to intersections. Select all and recalculate normals in Edit mode.

Lastly object scale is uneven. It doesn't prevent Solidify from working but it does give unexpected result, on the image below left is before scale applied, right one is after. To apply scale in Object mode press Ctrl+A.

enter image description here

$\endgroup$
  • $\begingroup$ tank you much! I really understtod. I forgot face orientaion during solidification, so I didn't realize why such results. I'm a little still confused about what I did to have double vertices (but I'm really newby). A little last question: it's right in these cases use new mesh circle + (modified) plane and join them to have such a geometry? or it's better to use paths or poliline/bezier? tank you a lot, I made a more little step to learn how to draw.. (hope) $\endgroup$ – Marco Mar 8 at 12:50
  • $\begingroup$ @Marco in the example above object was created from cylinder, several faces extruded and scaled. However it seems way of modelling is generally personal preference. For example modelling with curves might be easier - just to trace the profile (Ctrl+Left click in Edit mode to extrude) and then use Bevel and Extrude options of curve object. It all depends on how precise object has to be and what are you more comfortable with $\endgroup$ – R El Clein Mar 8 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.