4
$\begingroup$

I tried it on a fresh project and there I was able to successfully apply automatic weights. Here if I try to do it with empty weights I can't select bones in weight paint mode, so that's not an option. I tried searching for answer but couldn't find any. Any help is greatly appreciated :)

enter image description here

$\endgroup$
  • $\begingroup$ To select bones in weight paint mode see blender.stackexchange.com/questions/127805/… $\endgroup$ – Sazerac Mar 5 '19 at 23:28
  • $\begingroup$ I tried it but I can't select them anyway, however, on a fresh project I'm able to select bones in weight paint mode just fine. $\endgroup$ – Meowauth Mar 6 '19 at 13:34
  • $\begingroup$ Still having this problem and cant find a solution anywhere :( $\endgroup$ – Meowauth Mar 8 '19 at 22:53
1
$\begingroup$

I noticed that when I select Armature it highlights all my bones and when I press ctrl + p it seems that the automatic weights is missing as well.

If you're in Object Mode and you hit "a" to select everything, and then hit ctrl + p it shows the automatic weights in the context menu. Hope that helps :)

| improve this answer | |
$\endgroup$
1
$\begingroup$

If it help anyone: I had the same issue but was unable to solve this issue. There was no "automatic weights" in ctrl+p menu nor was I able to assign weights in any other way. After an hour of pain, the issue was that my mesh was disabled for selection. So dont forget to uncheck this option :)

| improve this answer | |
$\endgroup$
  • $\begingroup$ Nice answer. Could be improved to show a screenshot with annotations. $\endgroup$ – metaphor_set May 2 at 13:33
0
$\begingroup$

I had the same problem too. When I used Ctrl+mouse click (object data or vertex group) the automatic weight is missing, so the solution is to click on the rig then click the first object, then click the bottom object while holding shift and then when you click Ctrl+P it shows up. I hope that helps. enter image description here

| improve this answer | |
$\endgroup$
0
$\begingroup$

If you try to apply automatic weights to a curve or something like that be sure that you converted that to MESH with right click when object selected and convert to mesh option.

| improve this answer | |
New contributor
raskol nikov is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.