1
$\begingroup$

I have noticed that sometimes when I model some objects, some face later on appear to be a bit darker than others. Especially after texturing. I have checked the normals and they are pointing in the right direction. I have tried recalculating normals to see whether it fixes anything but no luck.

I also tried rotating the objects to see whether it is an issue with lighting. Sadly it isn't.

Also, this isn't caused by a normal or bump texture because the problem appears even before I start adding those. This is the third model I am experiencing this on.

I will appreciate even just an explanation to understand why this happens.

Thanks in advance.

enter image description here

$\endgroup$
  • 2
    $\begingroup$ Image doesn't point the defects according to your question $\endgroup$ – Yash Mar 5 at 14:54
  • $\begingroup$ Would you mind upload your file? $\endgroup$ – Jackdaw Mar 5 at 22:27
  • $\begingroup$ The defect is in the lower part of the plank in the image. It has exactly the same texture as the upper part and the sides, yet it appears to be significantly darker. $\endgroup$ – Sammy Albert Mar 6 at 2:30
1
$\begingroup$

when this happens to me i just select it and apply "faces>shade flat". if someone has a better answer please share.

$\endgroup$
  • $\begingroup$ You are right. Making it to shade as flat fixes it. But what happens when I need a smooth face. So this indeed is an issue. I'm glad I'm not the only one experiencing it because I thought I did something wrong. Thanks. $\endgroup$ – Sammy Albert Mar 6 at 2:34
1
$\begingroup$

The reason for this isn't normals, it's smooth shading accompanied with comparably low polygon count, look at the image, all three cylinders have identical mesh, the one to the left has flat shading, the one in the middle smooth, the one to the right is also smooth but with Edge Split modifier, I believe you're interested in the result to the right. enter image description here
SOLUTION:
you just need to add Edge Split modifier, the downside is making the edges that are below the angle threshold, very unrealistically sharp, but that's part of the price paid when working with low poly, if this result is not an acceptable option:
The other solution is to make some edge loops near the edges that are affected by the smooth shading, check the following images.
This is the result by adding some edge loops, or in general more polygons. enter image description here
And this is how the mesh looks like
enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.