0
$\begingroup$

Not sure where I'm going wrong with my texture painting, or if it's just a bug that keeps happening in various iterations of Blender.

I set a fill color, and use that to fill my space for the base-line color. I use Sample, and I set it to Mix Mode (it doesn't matter if I Sample from the Image Editor or the 3D View), with the Brush strength at 100%. It lays down a darker color than the color I sampled. I switch to Add mode, and now it's lighter. Add Brush Mode Mixed Brush Mode Why is it doing that? The Sample is exactly the same color. I even go back to Color Picker, create a palette with my base color, and use Fill, which works fine, but the Brush tool (using the palette color, no Sampled color) apparently doesn't want to match the color already applied, or it wants to Darken/Brighten the color.

If it's a problem with 2.8, fine. It's making me think I'd be better off using something like Krita. Yeah, it'll take longer, but it'll get me better results, I'm starting to believe.

Information Edit: For those curious. I was using the Workbench renderer(?), with Flat Lighting in the Shading pop-up menu (Lower Right corner of the 3D View). Current overlays are default (navigation, active mesh, active tool, etc.). It's a Principled BDSF material, if that alters anything?

Update: I ended up creating a new .Blend file and just moving my work to it, and now things work. This isn't exactly a -Fixed- issue, but I have the original file saved and will keep it around to mess with settings until I figure out what's wrong. Once the solution is found, I'll post it in a "Final Update" in the original post.

$\endgroup$
  • $\begingroup$ Can you include a screen shot of the problem and your set up?Also include what view overlays you are using, etc. $\endgroup$ – Craig D Jones Mar 3 at 0:23
  • $\begingroup$ Why are you using Add? Because you want to see a difference? I have tested her by sampling your colors both from the uv image editor and the 3d view and painted in both views with the sampled colors - also checking sample merged as well to make sure, and I get the same colors when painting using Mixed blend mode. I can only ask that you try your fill again and make sure you didn't accidentally switch to Multiply at some point. I set mine here at 1.00 with no pressure. $\endgroup$ – Craig D Jones Mar 3 at 0:31
  • $\begingroup$ So the brush is darker/lighter, but fill is okay? See if the Brush is using a different Mix mode than Fill is - each tool has their own. $\endgroup$ – Craig D Jones Mar 3 at 0:34
  • $\begingroup$ @CraigDJones When I used "Fill" I was in Mix Mode. I even went back to see if it was just something wrong with Strength percentage when applying the Fill, and NOPE, the color came out as seen in the Palette. And the brush still doesn't want to apply it correctly. $\endgroup$ – Orzene Tyranni Mar 3 at 0:35
  • 1
    $\begingroup$ @CraigDJones Okay.. it's a problem in the file apparently. I did a completely new -EVERYTHING- and appended the palette to the new scene. Mix Mode works as intended. Sooooo.. now I just need to find what setting I changed to fix it in the actual file. rofl $\endgroup$ – Orzene Tyranni Mar 3 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.