1
$\begingroup$

So I have this mesh that has a mirror modifier and I selected automatic weights for the bones and whenever I move the right side of the bones it does the same thing for the left side and I move the left side it just moves the bones but not the mesh. What is the problem? I know it has something to do with the mirror modifier I have on my character but I have to keep it for weight painting later on. Sorry if it is super obvious. This is my first time trying out armature.

Edit: So apparently it had something to do with making sure they had the right names, so no .001 or .002 on the end of the armatures and that they had the right order in the properties tab which is mirror modifier first and armature last. Also, you must apply the mirror modifier THEN assign automatic weights. Then you must make another mirror modifier on the mesh and delete the other half of the mesh, and then you have a mirror modifier AND have the pose working properly! That was pretty obvious but I was being stupid so I wasted 30 minutes trying to figure it out!

$\endgroup$
  • $\begingroup$ Please do not add "solved" as part of the title or put the answer as part of the question. Write a proper answer in the answers section and mark it as accepted instead. Please take the tour to understand how the site works. Read also: what does it mean when an answer is accepted? $\endgroup$ – cegaton Mar 2 at 4:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.