0
$\begingroup$

This question already has an answer here:

five month old newbie who's having some fun, here. I've been experimenting a bit, and got a problem. I was following this tutorial from Zacharias Reinhardt on how to create massive background forests via alpha channels. Seems to me to be the best method there is, if you're aiming for not too much processing. https://www.youtube.com/watch?v=BtUS8QTsVZA

And then I got stuck in the node editor when removing the black alpha channel part of the png. I'm 99% certain I did everything exactly like Zacharias showed in the tutorial, but somehow, I'm getting a somewhat different result? And yes, RGBA was selected during export of the original file.

I've added a screenshot of the section in the tutorial and a screenshot of what I've got on my screen. Any help would be greatly appreciated! :)

enter image description here

enter image description here

$\endgroup$

marked as duplicate by cegaton, Duarte Farrajota Ramos, Community Mar 1 at 22:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    $\begingroup$ Kind of hard to know what is wrong without the .blend file. Maybe try changing the color of the Transparent BSDF with the Alpha channel turned to 0 instead of 1 $\endgroup$ – WhatAMesh Mar 1 at 9:32
  • $\begingroup$ Hey WhatAMesh, my previous setup was from a saved template, so I redid everything from factory settings, only enabling the NodeWrangler and Image from Planes addon and got it to work. Thanks for the help. :) $\endgroup$ – Savage Sauron Mar 1 at 22:01
  • $\begingroup$ Hey cegaton, thanks a lot for the link. I'd exported everything as RGBA, and instead of drag/drop, used the Import Images as Planes addon this time and made sure enable "Use Alpha". This time it worked, but once I switched to Cycles Render it went completely white. So I started in Cycles and then it worked. And using Shift+Ctrl+Alt+C, I reset the origin/pivot point, so everything's working now again! (Still learning my way around SEs posting stuff. Pardon that.) $\endgroup$ – Savage Sauron Mar 1 at 22:03
0
$\begingroup$

To help troubleshooting, add an emission node and set it as alpha channel viewer, because it looks like there is an uncorrect alpha channel.

An useful shortcut for this procedure is to enable the Node Wrangler Add-on and Shift Ctrl click on a node a couple of times to temporarily view its output values.

enter image description here

Also checking the image in a 2D app (Gimp, Photoshop) could help, because the Blender setup looks correct.

$\endgroup$
  • $\begingroup$ Hey Josh, thanks. I added the emission and I'm seeing exactly what you're having. I got it to work with cegaton's help. Much appreciated! :) $\endgroup$ – Savage Sauron Mar 1 at 22:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.