3
$\begingroup$

enter image description here

Hello everyone, How to fix this physics problem, the objects pass trough to wall. I increased the Steps per second and Solver iterations in scene settings > Rigid body world. Also, I set the shape to Mesh in rigid body settings, but nothing happen...

Many thanks!

$\endgroup$
  • 4
    $\begingroup$ Check your Normals to ensure they’re pointing in the right direction. $\endgroup$ – Rich Sedman Feb 28 at 13:10
  • $\begingroup$ Thank you for your reply! I am a beginner in blender, with a past in cinema 4d, could you explain how to check the normals, please... $\endgroup$ – diniulian Feb 28 at 14:09
  • 1
    $\begingroup$ No worries - select your mesh and go into Edit mode (Tab) and then press N to open the properties panel (to the right of the 3d view). In there there should be a Mesh Display section with a Normals section. Enable ‘Display face normals as lines’ and you should see them shown on your mesh as short blue lines. Check they are pointing ‘outwards’ from each solid surface. If not, select the face and use Mesh/Face/Flip Normals to flip it to the other direction. $\endgroup$ – Rich Sedman Feb 28 at 14:27
  • 2
    $\begingroup$ Also, make sure you create your objects with a realistic scale (1 blender unit is effectively 1 metre) - large objects can result in unfeasibly large forces. If you resize anything make sure you Object/Apply/Scale to set that as the object’s actual scale to ensure you get realistic simulation. You can also set the object’s mass in the Physics panel - set it to something reasonable for the density of the object being modelled (eg, a cork ball will behave differently to a brass ball). $\endgroup$ – Rich Sedman Feb 28 at 14:32
  • 1
    $\begingroup$ Rich,thank you for taking your time to answer me. $\endgroup$ – diniulian Feb 28 at 14:34
3
$\begingroup$

When building a physics simulation it's important to ensure it fits with 'real world' proportions and properties in order to achieve a realistic simulation.

Firstly, ensure your surface Normals are pointing in the right direction. You can view your normals in Edit mode (Tab), opening the Properties side-bar (N), scroll down to Mesh Display and enable 'Display face normals as lines'. This will display short blue lines at the centre of each face to indicate the face 'direction'. For physics collisions to correctly detect 'inside' and 'outside' you should ensure your normals are all pointing 'out'. If you need to adjust the normals there is an option to 'Flip Normals' (change the selected faces to point the other direction).

Ensure your objects are all at a 'realistic' scale in the real world - if you haven't set a specific scale on your scene (eg, Metres, Millimetres, etc.) then you can assume 1 Blender Unit (the units that your dimensions of objects are measured in) will represent 1 metre. Note that the scale is important for the physics simulation - the forces resultant from a falling 0.01m x 0.01m x 0.1m block (eg, similar size to a Jenga block) will be considerably different to a 1m x 1m x 10m wooden beam - even though the proportions are similar.

If your objects have had their 'scale' adjusted (using the Scale tool) you should ensure you 'Apply Scale' to have their new scale affect the simulation. This can be acheived by selecting the mesh in Object mode, pressing Ctrl+A and select Scale.

Finally, set the object's Mass to a realistic value for the behaviour of that object you desire. This is available in the Physics panel of the toolbar panel on the left-hand side (T) by clicking Calculate Mass. This allows you to select the material of that mesh to use in the physics simulation, such as Cork, Iron, Brass, Concrete, etc. - or set a Custom density if none of the preset ones are suitable.

Note that it can be beneficial to increase the Steps Per Second and Solver Iterations settings above their defaults (60 steps per second and 10 iterations) but care must be taken when increasing them too high as higher values result in shorter "timeslices" each time Blender evaluates a "step" in the simulation. Shorter timeslices result in much smaller forces and motions and the precision can result in rounding errors, adversely affecting the accuracy and realism of the simulation.

$\endgroup$
  • $\begingroup$ While these points are good advise, the simulation in the gif showing the problem possibly only needs more substeps. $\endgroup$ – Leander Mar 6 at 7:57
  • $\begingroup$ @Leander True - although the question does state that steps per second and solver iterations have both been increased. As part of investigating the problem I did replicate this and increasing steps per second didn’t solve it (and increasing too far can actually adversely affect the simulation - presumably by rounding of the calculation of the progressively smaller forces for smaller steps). $\endgroup$ – Rich Sedman Mar 6 at 8:03
  • 1
    $\begingroup$ That sounds insightful as well (and increasing too far can actually adversely affect the Simulation), I think it would make a good addition to the answer for people who are only experimenting with high step sizes. $\endgroup$ – Leander Mar 6 at 8:06
  • $\begingroup$ Good point @Leander - I've edited the answer. $\endgroup$ – Rich Sedman Mar 6 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.