1
$\begingroup$

2.8 is currently unusable for me, the program is not recognizing any keyboard keystrokes and will only allow me to select things with the mouse.

The middle mouse button does not register anything and I cannot select anything inside of the actual viewport. I am able to select buttons on the side and on the top menu, cannot pan or zoom.

All relevant drivers are up to date. I have tried using other keyboard/mouse combos with no luck.

I have tried to reset my preferences to factory.

Processor: Intel® Core™ i7-6800k CPU @3.40GHz Ram: 16gb Windows 10 GPU: Nvidia 1080

Here is the problem in action, in this I am trying to use my keyboard shortcuts, the mouse. I get a weird “Internal Error” pop up as I mouse over the viewport buttons on the left.

enter image description here https://imgur.com/jcu8HNQ

I have been having this problem with 2.8 for awhile and it has kept me from using the program out of frustration. 2.79 works for me, I am able to work inside of the program with no problems at all.

I am at my wits end here with this.

$\endgroup$
  • $\begingroup$ Start blender from terminal blender.stackexchange.com/questions/21772/… paste any relevant errors into question. $\endgroup$ – batFINGER Feb 28 at 4:16
  • $\begingroup$ I've had the same issue ever since Steam applied the update to 2.8. I already had 2.8 installed and it wasn't a problem then, but after the update replaced 2.79 with 2.8, this has been a recurring issue. Deleting the userpref.blend seems to fix the problem, but when I try to activate an addon or change the preferences it comes right back after the next restart. $\endgroup$ – Metalraptor Sep 1 at 20:42
1
$\begingroup$

Thank you for stating your question clearly.

Go to c://users/yourmachine/application data/roaming/blender foundation/blender/28 <-- this last folder should be the one with old preferences and is conflicting with other 2.8 installations. Delete it.

Run Blender 2.8 choose your default selection click but DO NOT change keyboard layout.

Your Blender 2.8 version should be up to date (daily developer version or DD).

Dowload Blender 2.8 DD. Unzip and run from the unzipped folder. Your configs should be reset to defaults and you should have no trouble driving Blender 2.8

And oh! please, please, close the antivirus totally and make sure the application is not firewalled on your windows configuration. Give firewall permissions to execute 2.8

Thank you for your consideration to select this as the answer.

BFCT_Schiller

$\endgroup$
  • 2
    $\begingroup$ If you believe a question is clear and well stated consider upvoting it. $\endgroup$ – batFINGER Feb 28 at 4:05
  • 2
    $\begingroup$ This absolutely fixed my problem, lifesaver. $\endgroup$ – FuriousTribble Feb 28 at 15:03
  • 1
    $\begingroup$ Please click on the "check" mark button on the left side of my answer to mark it as "answered". Thanks. I am glad it worked for you. $\endgroup$ – Pierre Schiller Feb 28 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.