0
$\begingroup$

While rendering I get a display driver stopped working error. Drivers are up to date, I got a 1060. Not too long ago I formatted my pc and I could render with no issues. Now I can't. It just happens when I make full renders at high quality (around 1000 samples). I was used to render more complex scenes even at 2000 samples. Any advice?

Lately I've been having issues with my hard disk, but I don't think it is related.

$\endgroup$
2
$\begingroup$

The issue is not with the driver per-se, but with Windows.

The operating system has a builtin timer for when the graphics card is busy. If the graphics card doesn't respond for more than a certain period it activates a count down. When exceeded it terminates the graphics drivers process to regain system responsiveness.

As Julian Herzog writes

The problem here is that Windows has a timeout detection and recovery (TDR) system that detects if a GPU computation takes longer than a given amount of time, the default value for that being two seconds, and then “reinitializes” the Windows Display Driver Model (WDDM) driver and resets the GPU. This will stop the rendering process. You will also notice that any displays attached to the GPU you use for rendering will turn black for a short moment.

Normally, this system is great because it prevents permanent screen freezes for malfunctioning drivers or games. But in Cycles, one sample is considered one computation, which means that if your sample calculation takes longer than two seconds, Cycles (and the Blender UI, if you render with UI) will crash.

To prevent this you must change a key in Windows registry

  1. Open the registry editor (REGEDIT)
  2. Got to HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/GraphicsDrivers
  3. Set the TdrDelay DWORD
  4. If it contains a kyword named TdrDelay edit its value
  5. If there is no TdrDelay right-click into the empty space below the values
  6. Create a new “DWORD-Value". A DWORD (32-bit) -Values hould cut it
  7. Set its name it “TdrDelay”
  8. Change the value to 8 or 16 (value is interpreted in seconds)
  9. Beware of the editing mode, make sure you save as decimal value, not hexadecimal (I found only 512 was enough to prevent most crashes).
  10. Reboot your system for the changes to take effect.
$\endgroup$
  • $\begingroup$ it didn't solve the issue.. also I never had to deal with this before the format.. I wonder why this is an issue now.. $\endgroup$ – Raio Boss Feb 27 '19 at 18:04
  • $\begingroup$ what blender version? 2.79b or 2.8? I've have the ongoing problem as you described but only for 2.8. $\endgroup$ – kite Mar 30 '19 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.