0
$\begingroup$

Ive been using blender 2.79 without problems for some time. I've recently downloaded blender 2.8 in which a very basic problem appears.

In cycles, when in rendered mode, the viewport behaves very strange. It will not update any shaders. It will not update the position of a light source until I go out of rendered mode and back in again. When using nodes for a light source, after changing any parameters the light will just behave as an infinitely strong source.

These problems seems to only be present in the viewport, it renders fine.

If the project is saved, it will display the correct shaders in the viewport in rendered mode. But again, will not update if I make any changes.

Is this because of my GPU? Seems like it should be supported with 3d gen GCN.

Under Blender Preferences > Cycles Render Devices it says "no compatible GPUs found" for Open CL.

Im running on MacOS Mojave Version 10.14.3 iMac (Retina 5K, 27-inch, Late 2014) 4 GHz Intel Core i7 32 GB 1600 MHz DDR3 AMD Radeon R9 M295X 4096 MB

What do?

$\endgroup$
  • $\begingroup$ OpenCL rendering is no longer supported in Blender on Macs.read: blender.stackexchange.com/questions/128693/… $\endgroup$ – cegaton Feb 27 at 14:12
  • $\begingroup$ I see. Sorry for my technical non-knowhow, but does that mean the rendering in the viewport has to be driven by gpu, and the reason it works when actually rendering for real is that it uses the cpu then? $\endgroup$ – Joacim Svedlund Feb 28 at 9:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.