1
$\begingroup$

I just made a walk cycle with an armature and when I simply move from the walk cycle action to another action the armature changes location. Here's the first screen capture before I switch actions.

armature before switching actions

Here's what happens when I switch actions

armature after switching actions

I should say that when I imported this armature the bone connections where messed up. In fact I couldn't find them, just sticks and circles. But I did my best to make a great looking walk cycle. Tried changing the armature location and adding new LocRotScale info to each keyframe but that didn't fix the problem.

$\endgroup$
  • $\begingroup$ it must happen because the armature object itself must have been keyframed and this animation must be part of the action you select. If it's the case you can see that in your Dopesheet, on the bottom of the bones tracks, there's a track called LocRotScale and it's the one for the object itself, if you delete all the keyframes of this track it may fix the problem. $\endgroup$ – moonboots Feb 26 '19 at 19:00
  • $\begingroup$ That armature has about 100 different sections. I just can delete each locrotscale of each section. $\endgroup$ – genkaiten Feb 26 '19 at 19:35
  • $\begingroup$ I fixed it. What I did was change the cursor location to be under the armature and then I changed the armature's origin to the cursor location $\endgroup$ – genkaiten Feb 26 '19 at 19:39
  • $\begingroup$ ok, not sure what was your problem but if you fixed it... ;) $\endgroup$ – moonboots Feb 26 '19 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.