0
$\begingroup$

I've been fighting with noise in my render. For draft renders I clamp the AO bounces in simplify, which clobbers the noise, but also the shadows. And I don't like that. So for a final render I want to turn that off. However the noise sky rockets, as you'd expect. Then I hit on the idea of removing the glass from my windows, and the noise almost vanishes.

Here's the render with glass in the windows:

enter image description here

And here it is with no glass in the windows:

enter image description here

It's not only less noisy, but brighter too. Both these are done at 128 samples with denoising intentionally turned off.

So how can I have glass in the windows and not cause the dimming of the light and the increase in noise? And why should glass cause such a massive difference?

My glass is simply a cube with this texture:

enter image description here

And yes, there's a portal in the window.

$\endgroup$
  • $\begingroup$ Do you have reflective and refractive caustics enabled or disabled? $\endgroup$ – Brenticus Feb 25 at 16:00
  • $\begingroup$ At the moment both are enabled. With it disabled it goes almost black. I could crank up the HDR brightness, but the noise is still as bad as ever. If not worse. $\endgroup$ – Majenko Feb 25 at 16:01
  • $\begingroup$ What about just disabling refractive? $\endgroup$ – Brenticus Feb 25 at 16:02
  • $\begingroup$ Disabling refractive caustics only gives me very dark and noise. Disabling reflective only gives me a dim noisy image similar to the first image above. $\endgroup$ – Majenko Feb 25 at 16:04
  • 2
    $\begingroup$ Don't use the principled shader for the window. Use a modified glass shader Read: blender.stackexchange.com/questions/47851/… $\endgroup$ – cegaton Feb 25 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.