I have a fairly complicated material node tree that I'm building. All of a sudden some of my node inputs seem to be locked. If I click on an unconnected node input and change a number it immediately resets back. Dragging it as a slider does the same thing. Is there a way of locking nodes that I may have triggered with a keyboard shortcut?

I've tried digging into the API in the outliner but I can't figure out what's going on with these nodes. Only some of them seem to be affected, including both node groups and built-in nodes. Of course I've tried the last couple builds of Blender but they're still locked. I've rebooted too. I really don't want to have to rebuild this thing.

Blender 2.80.0 6bab905c9d40 on Windows Pro 64 bit

  • $\begingroup$ Can you provide us with the .blend so we can better understand the problem? $\endgroup$ Feb 24, 2019 at 23:55
  • $\begingroup$ If you hit I-Key (i) they may be tied to a keyframe. $\endgroup$
    – dval
    Feb 25, 2019 at 0:14
  • $\begingroup$ How do people normally post their Blend files on here? $\endgroup$
    – user69717
    Feb 25, 2019 at 0:31
  • $\begingroup$ If I append the material to a brand new file those nodes are still stuck. I'm guessing it's just corrupted data. $\endgroup$
    – user69717
    Feb 25, 2019 at 0:52
  • $\begingroup$ Just try the latest build of blender if it's latest try older then, I have some weird issues and most times it's fixed by downloading latest build. $\endgroup$ Feb 25, 2019 at 1:58

1 Answer 1


EDIT: Sorry to edit this after a moderator tweaked it, hope I'm not breaking any rules but it happens with key frames as well. It seems that ANY animation remains for that socket. The rest of the post is still accurate except key frames show up in the timeline (etc) rather than the driver editor.

--Original Post below--

I believe it's a driver issue, I've noticed with my node group that if I change the order of the inputs when there's a driver affecting one of them, that driver still affects the same numbered socket if that makes sense.

My fourth input I had #frame driving the value, then moved it up two spots and the value now in fourth was being animated despite not being animated before, and, there was no mention of drivers when right clicking the value where it typically says Edit/Delete drivers but it is mentioned in the Driver Editor though.

Blender version 2.93.6


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .