0
$\begingroup$

I can't get certain shadows to show in BGE. I have the correct lighting with the sun and hemi lamps. hemi lampsun lamp When I'm editing in BGE, all the shadows show like I want. Editing But when I press p to play, all shadows still work except for one. The one that doesn't show while playing is a bunch of planes connected together, all of them with the same texture on it to make a clump of grass. Playing When I was making it on a different layer with the same lamps, the shadow it casted worked while editing and while playing. But when I moved it to a different layer with the same lamps, the shadows only worked when editing and not when I press p to play. I have no idea why. I'm using GLSL if that matters.

$\endgroup$
0
$\begingroup$

you need adjust this settings to correct the shadows projection in the bge and this apply in bge, blender render and cycles adjust this control of shadow Blender Render BGE Play game BGE Properties Before play

$\endgroup$
4
  • $\begingroup$ @GarrisonManson check the las images inside de answer, is very easy and very clear to understand. $\endgroup$ – user58715 Feb 26 '19 at 3:12
  • $\begingroup$ Thanks for answering my question, but when I was looking at your pictures I realized that when transparency is on, the shadows don't show. I turned it off, and the shadows showed up. However, the grass you saw in my pictures are a texture printed on to multiple planes. When transparency was turned off, the planes became visible, which I don't want. Is there a way to make the shadow of the texture show and the planes not show? $\endgroup$ – Garrison Manson Feb 26 '19 at 15:08
  • $\begingroup$ I figured it out! The shadows were there all along. Your instructions were right. It was the size of the shadow that I had to fix. When I turned it to the max, the shadows showed up like I wanted. Thank you for helping me. $\endgroup$ – Garrison Manson Feb 27 '19 at 15:26
  • $\begingroup$ @GarrisonManson vote up my answer $\endgroup$ – user58715 Jul 1 '19 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.