This is the link of my video : https://youtu.be/vAUB8Zj4APg

Here's the link for the blender file : https://www.dropbox.com/s/fz7f0s0l3tl0ob1/gridfill.blend?dl=0

enter image description here

Basically i just want to create surfaces using GRIDFILL command. The left edges has no probelm while the right one give me weird error. I tried to find out what really happen but have no clue. Can anyone help ? i've attach my blend file to test.

  • $\begingroup$ do you have an eve number of vertices. Grid fill will not work with an odd number. $\endgroup$ – user1853 Feb 24 '19 at 18:35
  • $\begingroup$ why not ? i think as long as if you have same vertices number for the opposite edge, it should always works. $\endgroup$ – andio Feb 25 '19 at 1:18
  • $\begingroup$ Also that left surfaces (shaded one) has total 21 vertices and it works. $\endgroup$ – andio Feb 25 '19 at 1:25
  • $\begingroup$ youtu.be/hM4Z2FD74HE $\endgroup$ – andio Feb 25 '19 at 1:30

I'm not sure why it doesn't work the way you are trying, I would venture to guess it's a bug or a limitation of the algorithm, as there is no reason for it to work one way and not the other.

That said, you can still use the grid fill tool on the empty section if you select the two 'connecting' edges (the horizontal ones in the image above). You can also go into the settings of the failed gridfill and change the span to 6 and the offset to 1 and that works too.

Also, if you add geometry around all the edges it will work as well.

| improve this answer | |
  • $\begingroup$ as far as i think it's a bug. so far i can't find any reason why it's not working. But maybe i miss something here so that's why i attach the blend file to work with . It's for 2.8 . I tried to find the double vertices or possible mistake etc but got nothing. $\endgroup$ – andio Feb 25 '19 at 1:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.