0
$\begingroup$

Ive been trying to export an object that has 2 animations to the .fbx format, but when I export it back into blender instead of showing both animations playing, I just see one. On top of that in the action menu the action displays the same animation twice.

what I see once imported

This happens even though both animations are pushed down and the NLA strips option in exporting is checked.

pushed down animations in original file

I do know that I got it to work once, but I don't remember what I did to do so, because i've actually been tweaking export settings and redoing animations for 4 hours now. When I switch the order of the animations (e.g. move to top of list) it will also switch which animation is being exported. It will only export the animation on the bottom of the list.

If this is a bug in 2.80 that would really be a bad thing for me, since my computer doesn't support version 2.79

$\endgroup$
1
$\begingroup$

I'm not sure what your use case is, but I'm using this to import animations into Unity game engine. The NLA tracks thing doesn't seem to work with 2.8 and Unity, but you can have several actions created in the Dope Sheet --> Action Editor, and when you export, select "All Actions":

Export Settings

One thing that messed me up was that you have to completely delete the .fbx file and create a new one in order for Unity to recognize it properly and update the list of animations. Reimporting or refreshing doesn't work if you just replace the file that was already there.

$\endgroup$
  • $\begingroup$ Unchecking and then checking again the "Import Animation" checkbox under the "Animation" tab seem to work. $\endgroup$ – bmdelacruz Oct 10 '19 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.