0
$\begingroup$

This question already has an answer here:

I am trying to make a Minecraft Animation using Cycles Render. Everything is fine, but when I try to render or animate the animation, the background is empty or black.

Rendered + Environmental Texture Settings Render Layers

The only nodes that I used for the environmental texture are the 3 default ones, texture coordinate, and mapping (to move the background down and rotate a bit so that the sun would align with the HDRI image).

NODE EDITOR

I have used this image before on other animations, and this is the first time this had happened. One thing that is different is the Blender version, but other than that everything is the same (file location / name, image location / name, etc.). The regular image and camera settings are shown below.

Camera View + Render Settings Camera Settings

If anybody knows how to resolve this problem, help would be gladly appreciated!

$\endgroup$

marked as duplicate by cegaton cycles Feb 24 at 18:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2
$\begingroup$

If you replace your diffuse shader with a background shader it should work.

This is how it should look like.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.