2
$\begingroup$

I'm using Firefox 65.0.1 64 bit and have tried many times to download blender using a standard window, a private window, setting TLS back to 1.2 etc - however I'm still unable to do so because of the ssl_error_rx_record_too_long error I get on the page https://www.blender.org/download/Blender2.79/blender-2.79b-windows64.msi/ Does anyone have any other ideas of how to get Blender to download? Many thanks Isobel

$\endgroup$
  • $\begingroup$ I speculate that you might have some anti-virus feature switched on and that might have prevented the downloading of Blender. $\endgroup$ – Rita Geraghty stands by Monica Feb 23 '19 at 23:06
  • 1
    $\begingroup$ Possibly a certificate error. Check the date/time that your computer is set to - I’ve seen similar issues due to the date being incorrect (so the certificate was no longer valid). $\endgroup$ – Rich Sedman Feb 24 '19 at 0:16
  • 4
    $\begingroup$ I'm voting to close this question as off-topic because this is not related to blender, but is an issue caused by the configuration of the computer, OS, browser or network settings. $\endgroup$ – user1853 Feb 24 '19 at 2:44
  • $\begingroup$ I don't think (I accept I may be wrong) that the issue is with my computer. All the information I've read says that the issue would be on the download server itself, which is why I brought it here and not to Mozilla support, for example. My computer date is correct and I can download other software, so I don't think my anti-virus is causing the issue (it's ZoneAlarm and I've been using it for years). I'm interested to know if anyone else gets that error message from the download page? Many thanks $\endgroup$ – Isobel Feb 25 '19 at 12:05
  • 1
    $\begingroup$ @rob, thank you - I can download from the second link you posted. My system date/time is fine, but Firefox and Chrome both have an issue with the "official" download page (same error on both), so thank you for posting the lists. $\endgroup$ – Isobel Feb 26 '19 at 14:12

Browse other questions tagged or ask your own question.