1
$\begingroup$

I have a strange behavior with texture paint I cannot explain. When I draw at the Mesh, the paint appears on the faces on the other side of the mesh... see the picture. It's quite impossible to work with this. In the UV view, I am unable to draw at all the brush just not appears there. So has anyone an idea, what I could be doing wrong or how to fix this?

If not, is there a possibility I export the UV with the mesh lines on it? So I can use an external program to paint it?

Thanks very much in advance for any help!

enter image description here

This is the unwrap... Nothing is dangled or overlapping I already tried to reset the normals... but this didn't work either...enter image description here

$\endgroup$
  • 1
    $\begingroup$ I guess some faces of your unwrap overlay some others, so when you paint on a part of your mesh it will paint on another... how did you unwrap exactly? For this kind of painting the best and easiest way is to let Blender unwrap with the Smart UV Project option. $\endgroup$ – moonboots Feb 23 '19 at 10:17
  • $\begingroup$ perhaps share your file so that we can see what's the problem: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Feb 23 '19 at 10:34
  • 1
    $\begingroup$ With moonboots on this one. If you paint in one place and the texture comes out in several places at the same time, that suggests that the UVs overlap. Check the unwrap, pack your UV islands so they do not lie on top of each other. $\endgroup$ – Ben Feb 23 '19 at 10:45
  • $\begingroup$ Added a screenshot of the unwrap and shared the blend file. $\endgroup$ – Roca Teithmore Feb 23 '19 at 10:53
1
$\begingroup$

You need to apply your Mirror modifier before unwrapping, otherwise the faces will overlap.

$\endgroup$
1
$\begingroup$

This is because your mesh has inverted normals.

Then you paint over the faces that has inverted normals, blender thinks that the faces are rotated off the camera, so it doesn't paint on it. It is because you have enabled option Normal in Options. The option makes paint only on faces pointing towards to view:

enter image description here

In 2.8 you can see the direction of normals using face orientation overlay:

enter image description here

As you see most of the cloth (except collar) are red, that means what the faces is not pointing into camera.

And the main problem that the collar and other parts of the mesh are solid mesh, so you can't solve the problem using Ctrl+N (Ctrl+Shift+N), because if collar will be good, other mesh will be inverted, and vice versa.

So the conclusion: to fix that, you should to separate the collar, and then recalculate normals

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.