0
$\begingroup$

I have a mesh where one side is tilted (marked red in the image): enter image description here What I want to do is move selected vertices along the red line so that bottom line (marked white in the image) remains straight. When I move the selected vertices along the red line's local axis the bottoms line is getting bent in the middle.enter image description here
What I want is to move the selected vertices and get the bottom line rotated as one straight line. I just worked around by adding another straight edge. rotating it, subdividing it in the middle and then replaced the old edge with the newly created one.

enter image description here

P.S. I didn't use the rotate tool since I wanted the two sides to remain straight.

$\endgroup$
  • $\begingroup$ in 2.8 it could work with the reworked "shear" tool and local/normal orientation. $\endgroup$ – Chris Feb 21 at 22:41
  • $\begingroup$ I downloaded blender version 2.8 and didn't figure out how the shear tools could help me. $\endgroup$ – blablaalb Feb 22 at 9:58
1
$\begingroup$

I can´t see in which axis you did the capture but for Option A I will assume it is a TOP VIEW so: Select both of these RED circled vertex, now press S, SHIFT and DRAG to the RIGHT to scale them and make them align at SCALE 0 for both vertex.

If this is not what you expected, you can select and SLIDE the vertex you are interested by selecting the vertex and then press GG to move it

If this is still not what you expected, then select the vertex you want to align parpendicularly. Press X, D. Your vertex will be removed. Now, use the KNIFE (K) to make a clean cut from the appointed verted like in this graphic marked with the BLUE line as option 2. enter image description here

Thanks for voting me up on this question or selecting it as your answer.

BFCT_Schiller

$\endgroup$
  • $\begingroup$ Neither of your answers didn't work. The last one is basically just workaround; removing a vertex making a straight edge and then subdividing it again. Behind these vertices are more vertices perfectly aligned, they aren't visible since the view is orthographic. $\endgroup$ – blablaalb Feb 22 at 9:40
  • $\begingroup$ awesome, I just unlocked "more vertices under". With my answer. Amazing. Had we known that from the beginning I´d simply tell you to use SNAP options on VERTEX. $\endgroup$ – Pierre Schiller Feb 22 at 10:47
  • $\begingroup$ ok, your second suggestion worked :) I just slid the middle vertices out the way, and then slide them back $\endgroup$ – blablaalb Feb 22 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.