1
$\begingroup$

Just started Blender and working through tutorials. Most things I've been able to find an answer to, but this I missed somewhere.

When I'm working with created objects they appear dark. That presents a problem when working with detail, such as the beveled edges of a cabinet door below. Andrew's working objects are much brighter, which highlights the detail.

What I've tried so far is changing lights, textures, etc. However that seems to only apply when rendered in those specific view modes. Any help in the right direction is appreciated

Here is what I currently see: My dark objects

This is what I'd like to see: Andrew's bright objects

$\endgroup$
2
  • $\begingroup$ Normal direction can have some influence on the viewport shading already, did you try to recalculate your normals? $\endgroup$
    – Chris
    Feb 21 '19 at 22:44
  • $\begingroup$ I didn't try to recalculate normals, but I did make everything Double Sided which helped. This still didn't provide the clarity in detail needed to make fine tuning adjustments. $\endgroup$
    – Sam Vimes
    Feb 22 '19 at 3:13
2
$\begingroup$

In Blender 2.79 both Blender Internal (soon to be retired in favor of EEVEE in Blender 2.8) and Cycles renderers give you the opportunity to assign materials which have a color in the viewport in 'Solid' mode.

Select the object and go to the Materials tab in a Properties editor (you have one open underneath you Outliner, on the right of the 3D view)

In Blender Internal, simply assign a material to the object. Its color will show in the viewport.

In Cycles, assign a material, and, in the Viewport panel of the materials tab, give the material the color you would like to be displayed in the viewport in 'Solid' mode ... Switching to 'Material' mode will show you the color of the Cycles material, and can give you more control over the brightness of the viewport representation of the object.

$\endgroup$
2
  • $\begingroup$ I believe this is part of the issue after reading something else online. While the tutorial had not applied any of these settings yet, someone mentioned that adding Archimesh objects while in Blender Render will not have any default materials. Instead one should switch to Cycles Render first before adding Archimesh so they will display properly. $\endgroup$
    – Sam Vimes
    Feb 22 '19 at 3:27
  • 1
    $\begingroup$ I redid the scene with all the suggestions, and this was the overall issue. By using the default Blender Render, the default archimesh objects don't have materials (using Blender 2.79b). In that case they need to be assigned as you suggested. Alternatively, setting Cycles Render before starting the project gives them default materials. $\endgroup$
    – Sam Vimes
    Feb 22 '19 at 19:54
1
$\begingroup$

Try using matcaps, they are especially good at highlighting details

enter image description here

$\endgroup$
1
  • $\begingroup$ This helped a lot. There was still a lack of color contrast that he had in his Object/Edit modes, but this allowed me to finish out the fine detail. $\endgroup$
    – Sam Vimes
    Feb 22 '19 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.