0
$\begingroup$

(Note: there are many questions about smoothing - but this does not seem to be a duplicate of those. I referenced some at the bottom of this post.)

I have a column. It should be smoothed around the z-axis, but not along horizontal edges.

  • I tried "Auto Smooth", but that did not have any effect at all (and I do not know why). So I disabled that option again.

  • So I pressed "Tools"->"Smooth" in Object-Mode, which smoothed all of the object (as expected). Then I went into Edit-Mode, selected the edges that I need to be sharp and pressed "Shading/UVs"->"Edges"->"Sharp". I thought it had an effect at first... but it seems not to. enter image description here

Question: Why did neither "Auto Smooth" nor "Edges"->"Sharp" work for me?

Regarding duplication:

  • The answer to this question does actually split the edge into two edges, which a) I would like to avoid, and b) does not answer why the obvious ways did not work.
  • The answers to this question offer a collection of fascinating ways to smooth/unsmooth things... but do also not answer my question of "why".
$\endgroup$
2
$\begingroup$

"Sharp Edges" only works in correlation with the option "Auto Smooth" enabled. Auto Smooth uses the angle of edges standing on each other to determine if they should be shaded flat or smooth. The input "angle" is the starting point, so if the angle > 50° the faces will be shaded smooth

You could see the option "mark sharp" as an overwrite for the auto-smooth shading. "mark smooth" is essentially just a reset to default, or in this case the shading determined by the auto-smooth. Thats why only mark sharp has a visual edge highlight in the viewport.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you. I would say this is a non-obvious behavior on blender's part... It is good that I learned that connection, instead of just finding a work-around. Since blender is open-source... I wonder what could be done to clarify/solve this somewhat obscure connection. $\endgroup$ – Rororo Feb 21 at 10:50
  • $\begingroup$ i think a notification in the info-bar if the functions "mark sharp" or "clear sharp" are used, without "Auto-Smooth" enabled woud be a start. The tooltip you get, when hovering over Auto-Smooth, is quite helpful already i think. Thats probably like 2 or 3 lines of code. $\endgroup$ – Chris Feb 21 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.