when I move an object it's snapping every 1.0000 increments without me holding anything just move it. unlike when you move it smooth. unlike normal when you open the software

can you please tell me how to fix it

sorry for any spelling mistakes

  • $\begingroup$ it happens in the Node editor as well $\endgroup$ – Sasha simonnet Feb 20 '19 at 20:56

Welcome to Blender stack Exchange!

That's because of an option called 'Snap During Transform'. It's a little magnet icon in the toolbar at the bottom of the 3D view (in Blender 2.79b and earlier) or at the top center of the 3D view (Blender 2.80 and later). The keyboard shortcut is Shift+_Tab. I find those keys very easy to accidentally bump because of the other shortcuts Blender uses. Disable it and you should be good to go.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.