0
$\begingroup$

enter image description hereFor some reason, whenever I do a test render with Shift + Z, all I get is my character and the world is black. In the World properties, I have a Sky Texture with a strength of four, but it still shows as black. The only thing it effects is my character. Also, I'm wondering if this is related to why I can't get my character's shadows to render/show on a separate Render Layer...? I do have some Nodes set up, but deleting all of those hasn't fixed the issue, so I'm not sure if they're to blame.

Any advice?

enter image description here

$\endgroup$
  • 1
    $\begingroup$ in the Render settings is Film/Transparent checked? $\endgroup$ – rob Feb 19 '19 at 15:28
  • $\begingroup$ Ahh, yes, of course. I totally forgot about that. Thank you. :D $\endgroup$ – DustyShinigami Feb 19 '19 at 15:38
  • $\begingroup$ I don't really see the point in creating a new thread because, to me, it's the same issue. My compositing is pretty much finished, but when I go to render, the video footage isn't being rendered out. My character does, but everything else is a black screen. I've attached an image of my node setup. $\endgroup$ – DustyShinigami Feb 19 '19 at 16:54
  • $\begingroup$ You need to learn how to troubleshoot your nodes with a viewer node. Switch the bottom window from the time line to a UV/image editor. Render by pressing f12 so that the compositor has some information to work from and then plug in the viewer node to the beginning of your node tree so that you can understand what each element is and how is getting transformed along the chain. Other advise: Images with alpha are better combined with an Alpha over node. Also, NEVER use the slider labeled "premultiplied". Alpha channel can be Premultiplied or not, Half way makes no sense at all. $\endgroup$ – user1853 Feb 19 '19 at 17:21
  • $\begingroup$ Read: Environment looks fine in rendered preview mode, but completely black in final render $\endgroup$ – user1853 Feb 19 '19 at 17:22
0
$\begingroup$

I had this same issue with Blender 2.8

This worked for me :-

under View Layer tab, select Filter drop down and make sure that the Environment Checkbox is checked

Hope this helps

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.