1
$\begingroup$

I'm new to blender, only my second day, and I am following a tutorial by the Blender Guru. I noticed something wasn't quite right when he had live render running and his blender was running just as usual, however my computer seemed to struggle running blender, and it would also cause youtube to hang up and stutter. However when I go to render a simple scene containing a plate, doughnut, and a mug it crashes. The crash makes both of my monitors go black, except for some noise in the top third of my 2k monitor, little squares of color. Then blender closes. I tried following what other people suggested where it was applicable, making sure my sub-surf was only at 2 for everything when it was rendering and setting my memory usage to zero to allow for unlimited memory. However nothing seems to work. Any help on this would be amazing as I'm hopping to continue using this application into the future.

EDIT: So we just tested it on my s/o's machine and we have the same monitor, ran just fine with hers all the way up to 4k, she has older generation cpu AND a step down in both gpu and memory, memory only 16gb.... what is the deal?

System Specs-------------------------------------------------------------------- OS: Windows 10 64-bit Memory: 32gb ddr4 GPU: Nvidia 1080ti CPU: i7 7770k(over-clocked) Monitor: 2k dell monitor connected with display port

$\endgroup$
  • $\begingroup$ Try running blender from console with the debug flag set, so we can get a more specific error message. Also maybe attach the scene that makes your blender crash and mention the blender version. $\endgroup$ – WhatAMesh Feb 18 at 20:34
  • $\begingroup$ Sounds good I will do that, I'll look up how to run from console so I don't have to clutter this thread with another answer, thanks! $\endgroup$ – Elijah Pryor Feb 18 at 20:38
  • $\begingroup$ i hate to say it but i coulndt figure out how to run it from cmd line, another user told me to just treat it like corrupted data so I'm going to try that. If it still doesnt work i will try this! $\endgroup$ – Elijah Pryor Feb 19 at 0:49
2
$\begingroup$

This is a corrupt file on preferences. I´m sorry but you´re going to start blender anew afresh, asap. :) go to: C:\Users\3DCompositor\AppData\Local\Blender\Cache Delete everything you got in there.

Go to: C:\Users\3DCompositor\AppData\Roaming\Blender Foundation\Blender\2.79 or 2.8 whatever of the two folders you have there: delete it.

I´d assume you don´t have many new configurations or shortcuts. But even if you did, clearing out these locations will grant you a fresh copy of Blender.

Also go to: C:\tmp And wipe out all traces of any myfile.blend you could have there.

START BLENDER and if you CAN´T and Blender still crashes, the second thing to check is a FAULTY ADDON. Do you remember having added an ADDON recently? IF so: Please uncheck it and delete it from Blender´s addon folders: C:\Users\3DCompositor\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons

Last but not least try to run blender after all of these operations with only 1 monitor (YES ONLY ONE AFTER CLEANING) for a regular 10 minute session. IF you don´t notice anything weird, proceed with the SECOND monitor (plug your monitors with your PC OFF!) Work for 10 more minutes using BLENDER. If you didn´t have any crashes, Turn off PC, connect 3rd monitor, and work with Blender for 10 more minutes.

If Blender crashes while you render while you have monitor A, B, or C connected you´ll know which one could possible be malfunctioning.

All right, thank you if you vote me as the answer.

BFCT_Schiller

$\endgroup$
  • $\begingroup$ some of the files that I see you referencing don't appear for me, would an uninstall work the same? $\endgroup$ – Elijah Pryor Feb 19 at 1:03
  • $\begingroup$ Ok so updated I re-installed it after purging the files from my computer. It looks like my 2k monitor was the problem but that is really frustrating, why would a monitor be an issue? Is there any fix to this? $\endgroup$ – Elijah Pryor Feb 19 at 1:17
  • $\begingroup$ Hi Elijah, please vote my answer with the ANSWER check button. ;) Thank you. Yes: Drivers on graphics card can make Blender jump. All the more with a faulty monitor. Cheers. $\endgroup$ – Pierre Schiller Feb 20 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.