2
$\begingroup$

I am new to blender and I only want to take pictures of 3d model from the side. I have everthing set up. Camera is looking exactly from the side and set to orthographic.

But either I have a light which leads to surfaces being differently illuminated as they would in reality or I don't have a light and everything is black.

All what I want to have is the texture (jpeg) on my model as they are in the jpeg.

How can I achieve this?

Thank you:)

$\endgroup$
1
  • $\begingroup$ You could use the world lighting, basically a background illumination, which should lead to every surface being illuminated evenly. First delete every lamp in your scene, then go to world and adjust the horizen color. Alternatively you can upload your blend file with blend-exchange.giantcowfilms.com and I can have a look at it $\endgroup$
    – WhatAMesh
    Feb 17 '19 at 11:30
1
$\begingroup$

I'm not sure if you're trying to do this. Here's my solution:

enter image description here

  1. Hide all lights in your scene by selecting lights and pressing H.
  2. Set your world to white. If there's no color selection, you may check "Use Nodes" to create nodes before you change the world color.

enter image description here

  1. Use Node Wrangler. It's a built-in plug-in. Ctrl+Alt+U to call User Preferences. Go to Addons and search "Node Wrangler", and tick it, then save user settings.
  2. Go to Node Editor, and build up your materials for the object. Once finished, you want to make a solo preview of your texture, so press Ctrl+Shift+LMB on an image node of your diffuse BSDF to make it solo in preview.

enter image description here (The dotted line was the original line in final, but I make a solo preview of the texture, as you can see the Material Output receives input from a Viewer, followed with Image node.)

  1. Render, or make a viewport render, by Shift+Z.

enter image description here

Alternatively, You can also make screenshots in Material viewport.

enter image description here

Hope that helps.

$\endgroup$
3
  • 2
    $\begingroup$ Wow. Thanks for the effort. But I found out that it is enough to check "shadeless" under the material tab. $\endgroup$
    – Peter
    Feb 17 '19 at 12:18
  • 1
    $\begingroup$ haha I should congratulate you on your effort to dig out a onekey solution! $\endgroup$ Feb 17 '19 at 14:28
  • $\begingroup$ @Peter I can't find the shadeless option, where is it? $\endgroup$ Apr 18 '20 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.