3
$\begingroup$

enter image description here I like the shadow here but when the camera zoomed out, the shadow gone. Is this normal? how to fix this? enter image description here

$\endgroup$
  • 1
    $\begingroup$ Eevee is intended to produce 'good enough' results in near real-time, but does not always produce realistic results due to how it employs rendering 'tricks' and shortcuts to produce some effects (such as shadows and reflections). In your particular case, those shortcuts for generating the shadows are producing your unexpected result. Please edit your question to include enough information for someone to be able to replicate your problem - eg, lamp settings, scene setup, camera motion, etc. - and if possible also provide a sample .blend file so someone identify what's causing this in your case. $\endgroup$ – Rich Sedman Feb 17 at 9:31
2
$\begingroup$

I guess you are using a Sun lamp? Have a look at the Max Distance under the Cascaded Shadow Map.

enter image description here

$\endgroup$
1
$\begingroup$

This problem can occur if the camera clipping end distance is set too low. In a properties area select the camera icon then open "Lens" and set the Clip distances to appropriate values. Blender has several clipping values that apply to cameras, lights and their shadows, and view clipping.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.