3
$\begingroup$

I'd love to use SSAO in eevee to just add a little depth to my scene, but I've created a studio-esque lighting set up, and as such need to keep the world lighting dark, only lighting my scene with lights.

Is there a way to force AO in a dark scene? It seems like AO in eevee only works when the world is emitting light. Is there a workaround for this?

$\endgroup$
1
  • $\begingroup$ You have to consider that the A in SSAO stands for "ambient". AO is not occlusion of all light, but of ambient light. You can multiply your AO directly into your image textures if you'd like, but at that point, it's no longer SSAO-- it's just SSO, screen space occlusion. $\endgroup$
    – Nathan
    Mar 21 at 17:18
1
$\begingroup$

If you only need it in the final render, you can apply it in the compositor:

enter image description here

  1. Enable the Ambient Occlusion pass in Properties > Render Layers > Passes.
  2. Use a Mix node to multiply it with the render.
$\endgroup$
0
$\begingroup$

I faced a similar problem, ended up just plugging in the AO into the color input of Background. For your case the setup could've been a little trickier, such as using Mix/Add nodes, etc.

$\endgroup$

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .