0
$\begingroup$

i created a lime with material in blender. it looks good enough for me in blender editor. i baked it and saved as a png texture file to use in unity. but i could not get same output in unity with this texture. i have attached related ss repectively.

thanks,

blender ss which i like the same in unity

enter image description here

baked ss

enter image description here

unity ss which i failed

enter image description here

$\endgroup$
  • 1
    $\begingroup$ maybe you set up wrong your texture because it should appear with the bumps as the baked diffuse texture that u made. tho you can try to make a normal map instead of adding details to the diffuse to left the diffuse complete green color. $\endgroup$ – Michael Ben David Feb 14 '19 at 19:36
  • $\begingroup$ i am newbie at blender and i have not gotten what you said :( $\endgroup$ – yasin kaya Feb 14 '19 at 19:44
  • $\begingroup$ that could setted up wrong the texture in unity because it should appear like the bake that you done. $\endgroup$ – Michael Ben David Feb 14 '19 at 19:48
  • $\begingroup$ you mean blender side is ok but i can not set up properly in unity? if so could you share what it must be, please? because i tried many time with diffent setting notting has worked so far. $\endgroup$ – yasin kaya Feb 14 '19 at 19:54
  • 1
    $\begingroup$ It looks like you used "combined" for "Bake Type". Use "diffuse" with only "color" selected. Create a second texture for the normal map. Lots of tutorials on youtube on that. $\endgroup$ – metaphor_set Feb 17 '19 at 9:19
1
$\begingroup$

Confirm that your baked texture is saved to your Assets folder and is visible in Unity as an Asset in the Asset Window. Confirm that the texture is actually being set as the Albedo/Diffuse on the Unity Material. IF not Drag the texture from your assets window onto that setting in the Inspector. May want to set your Material Color to white as well so that the texture is setting the color now.

| improve this answer | |
$\endgroup$
  • $\begingroup$ i created baked image into my default folder and move it by drag/drop into texture folder under asset in unity here it is ss. and my texture settings is ss. and my object which i need to apply my texture, material settings ss. also i tried normal map in unity but nothing changed. $\endgroup$ – yasin kaya Feb 17 '19 at 20:29
  • $\begingroup$ Set the color to white. If it's still showing green but you can't see the texture details, the texture is showing but then something may be wrong with the UV map causing it to map to a very small part of the texture. In Blender, edit mode, select all the vertices and look in the Image/UV view to make sure they are mapped like they where when you baked the texture. Delete the .FBX model you are using and re-export it from blender, also rather than using the .blend file. Unity doesn't always do a good job of getting all the settings right when it exports the .FBX internally from a .blend file. $\endgroup$ – Benjamin Allen Feb 17 '19 at 21:10
  • $\begingroup$ i have exported it again as fbx file it looks work. but there are other issues. the texture i shared above is not suitable it has dark and light sides. it think that causes from the light when i had baked it. so i removed the light and re-bake but it created black one. i changed bake type from combined to diffuse it generate this one. i used it in unity but it is not what i created in blender. it must not be so hard to transfer from blender to unity :( $\endgroup$ – yasin kaya Feb 26 '19 at 7:42
  • $\begingroup$ Yes, you don't want to bake the lighting into it unless you need it, also Ambient Occlusion can look bad when baked, so just bake the Diffuse. In Blender, the method is a bit weird and tedious at first but once you get the hang of it you'll have an easier time and faster workflow. I noticed that in the 2.8 road map they are trying to make the workflow for game assets better, so look forward to that. Anything else probably costs a lot of money... but once you've used Blender for a few years everything can be done very quickly, just have to get good. :) $\endgroup$ – Benjamin Allen Feb 28 '19 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.