I was just 3d modeling as usual and I enabled the Archipack blender addon. Everything was fine until I tried to undo something and it didn't work. I went to a new project and the same thing happened. I moved a mesh in object mode and it wouldn't undo. My shortcut is CTRL-Z as usual.

I first disabled the addon, which did nothing. I then tried manually going to commands and undoing, and that didn't work. I then checked my keyboard in another program (It works fine). I tried all the blender stack exchange forms, and none of them worked. I updated windows, Gforce, and my driver (Still no difference).

Then as a last resort completely uninstalled blender and its cache, and installed the newest version, and still it doesn't work. I've studied my undo settings and everything, blender is refusing to undo!


2 Answers 2


You have to enable: Global Undo

For 2.8x and 2.9.

Edit > User preferences > System > Memory & Limits: Global Undo

enter image description here

For 2.79

Just go to Edit > Preferences > System & Setting, and check the Global Undo in Memory and Limits


Have a look in the User Preferences tab, and find the setting for undo. Make sure the undo steps count isn't set to 0.It might have changed by itself or something,It shouldn't but it's still a possibility. If that doesn't fix it good luck cause I have never heard of such a problem...

  • $\begingroup$ yah iv tried that, thanks though $\endgroup$
    – Sjam
    Commented Feb 14, 2019 at 3:48
  • $\begingroup$ I'm assuming The Memory limit is also at 0 Yes? $\endgroup$
    – CG Life
    Commented Feb 14, 2019 at 4:01
  • $\begingroup$ And try control W and see if that works $\endgroup$
    – CG Life
    Commented Feb 14, 2019 at 4:07
  • $\begingroup$ Try going through each viewport you had used and make sure everything is working correctly. Redo the operations you had done in a dummy form. Maybe you enabled a setting that caused the control scheme to change. For example I was playing in the vse and undo stopped working, turns out I somehow went into edit mode in the 3d viewport without accesssing the 3d viewport....was fixed by tabbing back to object mode. $\endgroup$
    – kite
    Commented Mar 16, 2019 at 4:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .