0
$\begingroup$

Who I am and what I do:

Hello People!

I am fairly new to 3D modelling (still using 2.79) and at the moment I am working on an M1 Abrams low poly tank (around 4600 Tris).

What I want to do is use a copied version of the low poly tank to add extra detail to it and then bake a normal map from the high to the low poly model.

I am used to the baking procedure in cycles render with small objects (like a cube for example). That means I am familiar with the setup (image, node etc.), ray distances and so on. Let's say the basic of basics of baking a normal map in Cycles Blender.

The Problem: It starts right away. I moved the copied tank (haven't added any detail to it yet) to the same position the low-poly has and I get this as a normal map:

enter image description here

What do I expect:

I thought that the rays will find no difference (surface) at all because it is the same model, right? So the image should be blank. Instead I get a lot of stuff and artifacts on it.

What I've already tried:

  • Playing around with Ray Distances (From 0 to 1 and between).
  • Added smooth shading to high and/ or low poly model
  • Removed Doubles, Rotation & Scaling

If somebody can help me?

Thanks!

Have a nice day.

$\endgroup$
  • $\begingroup$ I didn't understand what was the reason of baking shown on the screenshot (did you bake from lowpoly to lowpoly?), that said, yellow color on normal map usually means intersections in geometry. That might mean rays come long enough to cover lowpoly surface and then protrude into yet another layer of surface of lowpoly (e.g. areas where polygons are placed not far from each other towards each other, like indents, blocks etc) $\endgroup$ – Mr Zak Feb 14 at 18:32
  • $\begingroup$ @MrZak Hello, yes basically it was a "low poly to low poly" try. I was planning to copy my low poly so I have it twice to add detail to the copied version. With a cube for example this works. If you copy a unwrapped cube and put it to the same location it will produce a blank normal map because there is no change. If you add geometry to the copied cube this will be shown on the normal map. I expected the same kind of behavior to the tank seen on the screenshot. I separated the hull and the tracks for example and watched for no intersections but still it was showing the same results. $\endgroup$ – MARTHAL ARTS Feb 14 at 21:55
1
$\begingroup$

Your normals are inverted. Some of them are broken appart (they are not united) try going into edit mode and move them, you´ll see how they get appart and break from the original mesh. You got all traces needed since the normal map already tells you where this is happening. ALT+M will join vertex together (choose AT CENTER).

Another solution is to check out the normals. Definelty looks like the ones you have problems with are INVERTED NORMAL faces. Delete them from your model, recreate them in EDIT MODE and then select your object CTRL+N to average normals while in edit mode. Hope that fixes. It will certainly. Cheers.

$\endgroup$
  • $\begingroup$ Hello Pierre and thanks for the quick answer! When I created this tank I joined different Objects together. So for example I did the turret and hull separately and then when I finished them joined them together. Do I have to connect all the faces to each other (so every vertex is connected to each other) to make this working? $\endgroup$ – MARTHAL ARTS Feb 14 at 1:22
  • $\begingroup$ PS: Because I've searched and I think I've just found one face which was not propertly connected for some reason. But all other artifacts are still there and I cannot find faces which will break appart from the mesh the same way. $\endgroup$ – MARTHAL ARTS Feb 14 at 1:38
  • $\begingroup$ Check if they have NO MATERIAL. That also causes some conflict since it´s like the baking map doesn´t know where to shoot the ray. That seems like the probable cause. If it is, vote my answer up. Thanks. $\endgroup$ – Pierre Schiller Feb 14 at 1:56
0
$\begingroup$

@Pierre Schiller Thanks for your effort.

I don't think it is caused by inverted normals. I've checked the parts yellowed in the normal map. That would have been to easy. I spotted some vertexes which should be combined but it was not like a whole messed up topology. Some mistakes but fixed them quicky. Though it did not help sadly. Also I usually check faces when I build up a model anyway and use the remove doubles/ recalculate outside function a lot. Checked all faces and the outside is outside.

I think it has something to do with combining, could it? I mean I combined objects into one object and THEN I've tried to do normal map baking. Is this a problem? Since they have been one object but the mesh is basically not connected to each other. They are just treated as one object (CTRL+J in Object Mode). Also I checked the material. Everything is propertly assigned.

UPDATE:

So far I think this answer of user50810 is the solution.

https://blender.stackexchange.com/a/98266/69146

Thank you for your help and your time!

$\endgroup$
  • $\begingroup$ that its the answer for me, try baking individual objects. $\endgroup$ – Michael Ben David Mar 16 at 21:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.